First let me open with honesty, I am not a sysadmin, we are between them at the moment with our new one due to start in a few weeks.

We have been running multiple CentOS VMs on a CentOS host for some time. Last week however the VMs started to fail. Now when they boot sshd fails to start.

The issue started occurring around the same time as a kernel upgrade on the hypervisor. We use kvm + qemu.

The hypervisor is running Linux version 2.6.32-220.4.1.el6.x86_64 (mockbuild@c6b18n1.dev.centos.org) (gcc version 4.4.6 20110731 (Red Hat 4.4.6-3) (GCC) ) #1 SMP Tue Jan 24 02:13:44 GMT 2012

and one of the problem hosts is running Linux version 2.6.18-274.17.1.e15 (mockbuild@builder10.centos.org) (gcc version 4.1.2 20080704 (Red Hat 4.1.2-51)) #1 SMP Tue Jan 10 17:25:58 EST 2012

Manually attempting to start sshd via /etc/init.d/sshd start results in Starting sshd: /usr/sbin/sshd: error while loading shared libraries: /lib64/libcrypto.so.6: Invalid ELF header


"Invalid ELF header" generally means that the library in question isn't compiled correctly for your architecture, or that it's somehow been corrupted. It might be worth trying a reinstall of the package which provides that library. In CentOS 5 this is the openssl package. (See http://rpm.pbone.net/index.php3/stat/3/srodzaj/1/search/libcrypto.so.6 )

(If you can afford the space I'd clone the VM and try any VM-level fixes in the clone, or at least snapshot your current image. This may be overly paranoid, but I like rollback options in general.)

I'm not clear as to how an upgrade of your hypervisor kernel would cause this issue, but I admit I'm not well-versed on the internals of KVM. But, kernel upgrades generally don't remove the old kernel. Can you reboot the hypervisor into the old kernel? (You can generally select it at the boot menu.) If so, does the problem still persist? If this fixes it -- what was the motivation behind the kernel upgrade? Can you remain on the old version until you determine the root cause of your problem?

  • We've tried booting into all the available kernel options on the GRUB screen and they all exhibit the same problem, some earlier versions won't even start based on an error related to dracut. I think you're right regarding the kernel as there is another VM with the same kernel as the problem VMs and that's fine. I'll try the package re-install. – tojofo Feb 6 '12 at 22:09
  • FYI a forced install/update of the openssl package worked all though ldconfig spat out some errors during the install – tojofo Feb 7 '12 at 1:21
  • Glad to hear that solved your problem! – ajdecon Feb 7 '12 at 5:07

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.