I managed to install coova-chilli with freeradius and postgresql via apt-get and chilli's deb package in Ubuntu. And it works. For a couple of days, I'm struggling to install the same in CentOS 6.2. Here is what I have done:

Installed freeradius with postgresql under my directory (/path/to/my/freeradius). That works good. (Tested via radtest). Downloaded coova-chilli version 1.2.9, extracted it, and I have done the following from coova extracted directory:

./configure --prefix=/path/to/my/coova --with-openssl


make install

After I installed it, I tried to run it:

$ /path/to/my/coova/etc/init.d/chilli start

And I get the following:

coova-chilli[5600]: options.c: 180: could not generate configuration (/path/to/my/coova/var/run/chilli.5600.cfg.bin), sleeping one second.

So, can anybody help me on resolving my issue?

Thanks in advance!

N.B. I tried to put this question on coova-chilli forum, but I didn't get any answer. I also fallowed some posts on this topic, but without any result.

coova-chilli installation in ubuntu

coova-chilli installation in CentOS


Finally solved!

On short here is what I have done:

  1. downloaded CoovaChilli 1.2.9 and extracted it.
  2. In the extracted directory, I have done: ./configure --prefix=/my/prefix --with-openssl && make && make install
  3. edited the /my/prefix/etc/init.d/chilli and instead of $(which start-stop-daemon) I put $(which start-stop-daemon 2>/dev/null) details here
  4. configured /my/prefix/etc/chilli/config how it needed more details here
  5. finally, after a long struggle, I followed another one's 'thought', and I got it working: I created the /my/path/var directory, where I put a symbolic link to /var/run, called also run details here

All the best!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.