I am attempting to install RabbitMQ on a Fedora 13 box. This requires Erlang is installed. When I run yum install erlang I get the following messages. Yum seems to indicate that it resolved all the dependencies, yet it keeps failing to install. If I use the --skip-broken as yum suggests, nothing is installed. How do I resolve this?

http://pastebin.com/ETCBQ484 - Sorry for the link to the error, but the entire error yum session was too large to post here.

  • Fedora 13 is no longer supported, that is why the repo is broken – topdog Feb 6 '12 at 12:30

If you can't install the Erlang binary rpm from Fedora 16 on your 13 box, then it is pretty straightforward to build an Erlang 15B binary from the source code on erlang.org.

RabbitMQ and Erlang should not be treated as part of the system, but they should be treated as part of your application and kept up to date in your own local RPM repository.

Virtualbox is good for this because you can keep a build machine running Fedora 13 ready to build anything that you need, then deploy to your servers as normal.


As @topdog mentioned, this didn't work because F13 is no longer supported. I solved this problem by upgrading to F16 (current as of Feb 16, 2012).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.