I have this directory

drwxrwxr-x  6 awdfiles                pasgroup                4096 Jan 31 17:20 awdfiles

Which I want to access via another FTP connection. The user is part of the pasgroup

I traverse to the root html directory of my desired user and create the symlink

$ cd rayhawkpas/dev
$ ln -s ../../awdfiles awdfiles
lrwxrwxrwx  1 rayhawkpas rayhawkpas   14 Feb  6 13:06 awdfiles -> ../../awdfiles

However, when I try to download the directory in dreamweaver it looks like this

enter image description here

It seems to not recognize that it's a directory.

I tried symlinking to a specific file to make sure my permissions were right

ln -s ../../awdfiles/themes/1/includes/header.php test.php

This worked fine. It showed up in dreamweaver and I was able to download and upload the file.

  • What OS is this? Is it a Mac, or a Linux/Wine thing going on? – Soviero Feb 6 '12 at 21:27
  • Linux / CentOS. – Steve Robbins Feb 6 '12 at 21:32
  • Um... How are you running Dreamweaver then? – Soviero Feb 6 '12 at 21:42
  • Server is linux. My machine is Windows 7, CS5.5. I've done links like this before without issue so I'm not really sure what's going on – Steve Robbins Feb 6 '12 at 21:43
  • Oh! The symbolic link is on the server, and you are connected via ftp... This may be a limit/option of the FTP server. It would be a security issue to allow symbolic links over FTP because you could make it point anywhere... That's just my guess though... What hosting provider are you using? – Soviero Feb 6 '12 at 21:47

Your FTP Server is not configured to follow symlinks.
When configured this way a symlink will appear as a common file, just as you describe.
Change it's configuration. You haven't mentioned what software so I can't say how.

vsFTPd will not allow synlinks that link outside the user's chroot. There's no way around that.

A possible workaround is to mount the target of the proposed symlink as a subdirectory of the chroot environment. This is an ugly kludge, but the only way around the issue using vsFTPD.

A possible alternatives, install and use a different FTPd, or use a different protocol such as SFTP. I'm not sure if Dreamweaver supports SFTP, if it doesn't you can get around that with a utility that mounts SFTP drives as Windows Network Drives (I use such a utility, ExpandDrive, but there are others).

|improve this answer|||||
  • apache/centos.. – Steve Robbins Feb 7 '12 at 20:26
  • As far as I can tell followsymlinks is on. it's in my httpd.conf, virtual hosts file and htaccess – Steve Robbins Feb 7 '12 at 20:36
  • Unless you installed mod_ftp or mina, "Apache" is not your FTP software. While I'm at it, "Apache" is a company name, not software at all. They're most famous software is their web server "httpd". – Chris S Feb 7 '12 at 20:39
  • This is why I'm asking questions and you're answering them. If I knew what I was doing I wouldn't be here. – Steve Robbins Feb 7 '12 at 20:46
  • So what FTP software are you running then? – Chris S Feb 7 '12 at 20:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.