3

I'm trying to install CentOS 6.2 by kickstart, and I'm using the stock minimal ISO and the auto-generated anaconda-ks.cfg. After the installation finished partition the hard drive, I get an error message saying "Unable to read package metadata", and the /tmp/anaconda.log has the following line:

ERROR: Error downloading treeinfo file: [Error 14] PYCURL ERROR 6 - "Couldn't resolve host 'cdrom:sr0'"

My kickstart file:

# Kickstart file automatically generated by anaconda.

#version=DEVEL
install
cdrom
lang en_US.UTF-8
keyboard us
network --onboot no --device eth0 --noipv4 --noipv6
firewall --service=ssh
authconfig --enableshadow --passalgo=sha512
selinux --enforcing
timezone --utc America/New_York
bootloader --location=mbr --driveorder=sda --append=" rhgb crashkernel=auto quiet"
# The following is the partition information you requested
# Note that any partitions you deleted are not expressed
# here so unless you clear all partitions first, this is
# not guaranteed to work
clearpart --all --drives=sda
part /boot --fstype=ext4 --size=500
part pv.008002 --grow --size=1
volgroup VolGroup --pesize=4096 pv.008002
logvol / --fstype=ext4 --name=lv_root --vgname=VolGroup --grow --size=1024 --maxsize=51200
logvol swap --name=lv_swap --vgname=VolGroup --grow --size=512 --maxsize=1024


repo --name="CentOS"  --baseurl=cdrom:sr0 --cost=100

%packages --nobase
@core
%end

Please help.

3

I have solved this issue myself, the solution is changing the repo line from

repo --name="CentOS"  --baseurl=cdrom:sr0 --cost=100

to

repo --name="CentOS"  --baseurl=file:///mnt/source --cost=100
-1

I solved the same problem (in CentOS 6.5) completly removing the repo line from kickstart file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.