4

I have three disks. Disk0 (boot), Disk1 and Disk2. Disk 1 and 2 are both unformatted and unallocated drives. I am trying to mirror Disk0 to Disk1. They are both Dynamic and are both the same size (1TB). When I select Disk1 to be the mirror I get the error "There is not enough space available on the disk(s) to complete this operation". I have spent several hours searching for a solution but have not found one. Why do I get this error when they are both the same size?

EDIT: Shrinking the volume size on the boot disk by 100MB allowed me to get past this error. From what I read the mirror drive needs to be the same size or larger than the boot drive. So I am confused why that change worked. However, I now get the error " all disks holding extents for a given volume must have the same sector size and the sector size must be valid". I believe this is because the drives are different and one has 512B and the other is the Advanced Drive that is 4KB. What the different sector sizes cause both problems? If I got the same disks would both issues go away?

1
  • I don't understand the down votes... this is a legitimate issue that I cannot find a solution for. Instead of just down voting could you also provide a comment that can help make this question better. Thanks!
    – northpole
    Feb 8, 2012 at 16:58

6 Answers 6

2

A RAID1 array can only be as big as the smallest disk. Make sure that the volume you wish to mirror is the size you want it to be, then create volumes on the other physical disks that MATCH the size of the smallest disk. After all volumes are the same capacity, you should be able to create this array without issue.

This article here should help clear up some of the procedural steps:

http://www.techotopia.com/index.php/Creating_and_Managing_Windows_Server_2008_Mirrored_(RAID_1)_Volumes#Creating_a_Mirrored_.28RAID_1.29_Set_using_Disk_Management

Let me know if I can do anything else to help!

5
  • Thanks for the response! Right, so the two disks I am using are identical in size (1TB) but have different sized sectors. The boot disk has one volume which is the full size of the disk. Disk1 (the mirror) is completely unallocated. When I shrunk the size of the boot partition 100MBs I got passed the original error. Now I get the sector size mismatch error.
    – northpole
    Feb 8, 2012 at 17:42
  • These two drives, are they identical in terms of Manufacturer, Make, Model, Size?
    – JohnThePro
    Feb 8, 2012 at 17:45
  • The drives are the same size but different Manufacturers (so different make model as well).
    – northpole
    Feb 8, 2012 at 20:07
  • If you don't mind, can you provide me that information? As a rule of thumb, when building RAID arrays, you want to have identical drives, and even better identical drives from the manufacturing run.
    – JohnThePro
    Feb 9, 2012 at 18:34
  • johnThePro - This was it, it was the fact that the drives were not identical. Once they were the same it worked.
    – northpole
    Oct 9, 2012 at 22:07
2

Odds are the disks will need to have the same number of sectors for this to work. I believe that when Windows does the mirroring it does a sector by sector copy so as you have less sectors on the new drive it can't copy everything. As to the size issue, everything needs to be the same to the number of bytes. I'm guessing that the new disk with the 4k clusters is a few bytes different in size. Using a disk with 512 byte sectors that is the same size as the current drive should do the trick.

1

I had the same problem and managed to find a fix. I'll explain my steps and then give my interpretation of what happened.

assuming you have 2 disks, similar in size (diskA and diskB) also assuming you are already in Computer management (right click on My Computer and click manage)

In disk managment 1) create a simple volume for diskA. 2) right click on the volume you created and click Add Mirror (select diskB for the mirror) 3) This is where i got an error, however, it managed to successfully turn diskA into a dynamic volume. (yellow-green bar above diskA) 4) Create a simple volume for diskB 5) right click on diskB and convert to Dynamic volume 6) delete both diskA and diskB volumes 7) right click on diskA and create Mirrored volume.

My interpretation is that there is a flag on the volumes allowing them to becoming dynamic. Something in creating a mirrored volume from scratch and turning them into a dynamic disk was failing. Setting the flag for both volumes to be dynamic and then creating a raid drive worked.

Hope this helps

1
  • It ended up being a problem with the fact they were different types of drives. They needed to be exactly the same in all respects.
    – northpole
    Oct 9, 2012 at 22:08
0

Was just going through this in Windows Server 2012 R2. Have 2 Western Digital MyPasspor 4TB drives that I want to set in RAID 1 to backup the fileserver to. They were both exactly the same size in disk manager so I couldn't figure it out. What I did to get it to work was just change the size down by 200MB and that fixed it. There must be a minor difference in the drivers, or Windows doesn't like using the whole drive or something, either way this fixed it and it is working perfectly now. Hope this helps.

0

My drives were identical in MB.

Mirroring X-Drive then adding Y-Drive reported the error. Caused the drives not identical error.

My workaround/solution - was to reverse the drive selection. Mirror Y-Drive then add X_Drive.

0

The issue with the disks of same size (2TB or less) may be related to the hidden partition(s) of structures in GPT (for UEFI) and MBR (for BIOS). In fact, converting a disk from MBR to GPT or from Basic to Dynamic can keep inaccesible traces of old partitions and volumes only visible from diskpart.exe utility.

My suggestion is this: when you had to reuse a disk, it is better to wipe out (non reversible, definitive, and immediate way) the entire disk with the CLEAN option of the diskpart utility in order to clean the structure (GPT, MBR), hidden partitions, and volumes.

In a Basic disk (not converted to Dynamic) with existing partitions (hidden or not), the access to this previous partitions is lost during the conversion from Basic to Dynamic process. The new structure creates an additional hidden section (127MB) to support it and now the access is based on volumes (new partitions different from specials such as EFI or MSR don't work).

3TB (and greater) disks require GPT convestion in order to get access to media beyond 2TB (a limit of MBR structure), but software mirroring provided by Windows in this condition presents some issues with disks of different native sector size (4k native vs emulated) even with same size and brand.

In case of new deployments in baremetal servers, under this conditions, try with native BIOS RAID (Intel IRST / AMD RAID) or hardware RAID (motherboard-specific 64-bit RAID Storage drivers are required).

Some drives with data can be migrated to RAID from within Windows (Intel IRST for example) under some conditions, specifically if the BIOS have RAID option active in SATA configuration section during operating system installation.

(Based on my bad experience with Windows Server 2012 Standard in Toshiba DT01ACA300 as first disk and HITACHI 3TB as new second disk).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.