We've had Windows update problems in the past, where randomly different updates wouldn't install.

Usually I ended up hiding these updates and tried to forget about them. Eventually I unhid them and they suddenly magically went through. I just put it down to some combination of updates pushing everything to work - as you can see I'm not an expert by any means in this field so please bear with me.

New Error

For a while updates were OK, but then KB982671, Microsoft .NET Framework 4 for Windows Server 2008 RS x64-based Systems, fails to install. The error Windows update gave me (Note this is NOT WSUS, just standard Windows Update) was "Code 1 Windows Update encountered an unknown error." About as helpful as previous errors.

The WindowsUpdate.log contents can be found here.

I went to try get a few more details by turning on Windows Installer logging on verbose - the resulting log file is rather large so I've made it available as a HTTP download.

In that file I notice one error 0x8024000C. Searching for this issue took me to KB976982, which explained pretty much my situation. There was a Fix it download, however after downloading that and running it I was given the message "This Microsoft Fix it failed to process."

I also tried to manually download and install the update with the standalone installer from the MS Download Center site but this also failed. The error log it gave me was this HTML file

From this point I'm pretty stuck. Anyone with any ideas? Please ask if there are any further details I can supply you with. Here are a few general details:

Windows Server 2008 R2 Standard (64-bit) Service Pack 1


It was suggested I try a few things. I did, but they didn't work. I'll paste them here so you know I've tried these:


  1. Change the DisplayName value to:

C:\WINDOWS\SysWOW64\msiexec.exe /V

  1. Close registry editor.

  2. Now register the installer by opening a command prompt(Click on Start, type cmd in the >search box).

C:\WINDOWS\SysWOW64\msiexec.exe /regserver


Steps to resolve the issue:

Click Windows button and type 'regedit' in search bar. Click 'regedit' in search results

Navigate to following registry hive:


Check if following registry keys have correct values:

MsiExecCA32 should end with \Windows\syswow64\msiexec.exe

MsiExecCA64 should end with \Windows\system32\msiexec.exe

Re-run setup program after trying troubleshooting steps.


Also tried the suggestions at KB976982. Method one didn't work (the fix it gives an error - the manual steps show a problem description that isn't happening with me). Method two didn't work either - I used the cleanup tool (though, I don't actually see any .NET frameworks - so maybe just the default 2 or whatever it is installed with the OS?)

Then I went ahead and tried to install 3.5 instead to see if I could get that installed then update. It got as far as extracting and saying I'd need to use the role management tool to install it - to which is beyond me I'm afraid, and figured this was probably the wrong path to go down.

Note: This is cross-posted from Microsoft technet. Why? Because Microsoft support said post to answers, then they told me to post on technet, then they told me to contact support, then they told me to post on answers...

  • @syneticon-dj Thanks a lot for sorting out the URLs :) – Leonard Challis Feb 9 '12 at 16:09
  • You are welcome. Although I suspect that your log file is missing a crucial piece of information. It refers to the installation log from MSI_netfx_Core_x64.msi in %temp%\2 which would contain the actual error message. – the-wabbit Feb 9 '12 at 17:16
  • I have uploaded that file too - can't edit the above post however because of the same limitations. The file is here: dl.dropbox.com/u/36373004/… – Leonard Challis Feb 9 '12 at 20:28
  • 1603 is a tricky one if this is all you know. You should take a look at this list and try to do some troubleshooting. – the-wabbit Feb 10 '12 at 0:25
  • Tried all those suggestions - sadly this hasn't worked for me either. Onwards I plod... – Leonard Challis Feb 14 '12 at 4:56

Check your free space first, and go to Start > Run. Type in: services.msc. Find the automatic updates service and restart it.

Disable windows firewall and reset all security zones in IE > Tools option.

Uncheck "Require server verification" check box in IE > Tools > Security > Trusted sites.

  • Erm... No I don't think disabling all the security is a great idea. – Leonard Challis Jul 21 '14 at 7:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.