I have just installed and configured a ASA 5505 firewall (basic license) which has 3 VLANs (outside, trusted, untrusted) and the configuration is really basic.

Outside is for internet, trusted is for LAN computers, untrusted is for Wifi.

We have an internal server connected to trusted with a static ip of That server runs a Bind DNS instance. The server also runs 2 VPS instances. To make it easy to access the VPS instances they are given a domain name and the DNS instance is used to supply computers of the network with the ip for those VPS instances.

I tried to add the internal server as the primary DNS server and Googles public slave DNS ( as secondary:

mastermind(config)# dhcpd dns
address overlap with dhcp pool ip addresses

However that did not work. Do I need to reserve that ip so that it's not in the DHCP pool? Or am I going at this totally wrong altogether?

Relevant config settings:

ASA Version 8.4(1) 
interface Vlan1
 nameif outside
 security-level 0
 ip address dhcp 
interface Vlan2
 nameif trusted
 security-level 100
 ip address 
interface Vlan3
 no forward interface Vlan2
 nameif untrusted
 security-level 50
 ip address 
interface Ethernet0/0
interface Ethernet0/1
 switchport access vlan 2
# Ethernet0/2 to Ethernet0/6 has identical configuration
interface Ethernet0/7
 switchport access vlan 3
dns server-group DefaultDNS
 domain-name mastermind.local
object network obj_any 
object network obj_any
 nat (trusted,outside) dynamic interface
route outside 1
aaa authentication ssh console LOCAL 
ssh trusted

dhcpd dns
dhcpd auto_config outside
dhcpd address trusted
dhcpd enable trusted
dhcpd address untrusted
dhcpd enable untrusted

You're going about this correctly. I guess the reasoning for this error is that if your DNS server is dynamically configured there's a chance it could lose that IP address and break DNS for the rest of your clients. I would put a static IP on the DNS server and just change the DHCP range to exclude

  • Perfect. I just changed the pool to exclude the ip, and since the server isn't using DHCP it worked. Thank you! :) Feb 8 '12 at 15:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.