Successfully compiled and installed the latest version of samba.

Started winbindd and the following diagnostic commands work:

wbinfo -p, wbinfo -c, net ads testjoin, etc...

However! when using built-in Linux command like id or when using pam with pam_winbind module to login. They fail and there is nothing in the logs referring to winbind. What could be the issue?

e.g. [root ~]# wbinfo -i testuser
testuser:*:10708:1513:Test User:/home/domain.ad/testuser:/bin/bash

but !
[root ~]# id testuser
id: testuser: No such user

Note: previous versions (samba 3.5.x) worked well on our systems so it's not bad domain or configuration.


passwd: files winbind
shadow: files winbind
group: files winbind
hosts: files dns wins bootparams: nisplus [NOTFOUND=return] files
ethers: files
netmasks: files
networks: files
protocols: files
rpc: files
services: files
netgroup: nisplus
publickey: nisplus
automount: files nisplus
aliases: files nisplus

  • forgot to mention that in nsswitch.conf there are: winbind entries in the right places (otherwise the previous vers of winbind wouldn't work) – Alex Feb 10 '12 at 2:00
  • Can you post the actual (non-comment) contents of nsswitch.conf? – larsks Feb 10 '12 at 2:35
  • What is your backend - OpenLDAP, AD? We've never had much success with winbind and ended up disabling it, and things seem to work OK. – Andrew Feb 10 '12 at 2:53
  • @Andrew: we use Windows 2008 AD. If you disable it how can AD integration work? Note: it worked for us with previous version of samba package, but its very old now with listed vulnerabilities – Alex Feb 10 '12 at 3:22
  • @larsks: edited the question, pasted nsswitch conf – Alex Feb 10 '12 at 3:23


just had to run net cache flush and then restart winbind

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.