I need to run a small .NET 2.0 based application on a Windows Server 2003 based server.

I have successfully installed .NET 2.0.50727 from here and rebooted the server.

When I launch the application it is as though I never tried to - no error dialogs, just silent death. The Event Viewer shows an Application Error with the following info:

Source: .NET runtime 2.0 error
Event ID: 5000
Event Type: clr20r3

I'm assuming this is because the .NET framework has put one or more required DLLs in a different location to Windows XP (where this application runs without problem) and the application is looking in the wrong spot.

Is anyone able to point me in the right direction as to how to determine which missing file(s) the error is referring to?

I should add that I have tried running the application in XP compatability mode with no luck.


I am pretty sure your problem is happening before the application code even gets a chance to run - the error looks like it is coming from the CLR (Common Language Runtime), which is responsible for properly loading the application and any dependencies.

I have definitely had this sort of error at some point in the past, but I can't remember the exact cause. The discussions in this post might give you a few ideas though:


Also, if you use FILEMON.EXE to log activity while the program is launching you will very likely see an error on a file that can't be accessed or found. It can be a lot of log lines to dig through, but if you load up the log file in Excel it is pretty easy to sort through the data and find some clues.

Hope something here helps...


Sounds like you might be missing an app.config file that goes with your application. The exception is thrown while still starting the app, while trying to load the configuration file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.