Our print server is using cups, and it is set to use a classification but the classification is not appearing on the pages. The banner prints and all config files look to be okay (printers.conf, cupsd.conf, client.conf) and lpoptions shows the job-sheets with the right classification. We are not using user config files.

So what am I missing here? Why is the classification not working?

Cups version is 1.1.14 running on Solaris 8.

I captured some debug level logs of me printing with all the settings turned on. You can get them from http://zenorsoft.com/downloads/cups_logs.txt

  • Still not working... Anybody have any ideas? – MasterZ Jan 9 '12 at 16:28
  • It was recommended to use the page-label job option, but that did not do anything. page-label was added in 1.1.7 best I can tell, and I'm running 1.1.14 so it should be there. – MasterZ Jan 10 '12 at 16:53
  • I also turned on debugging when printing and in Startjob: envp string does include CLASSIFICATION=secret. Not sure what to check next. – MasterZ Jan 10 '12 at 16:54
  • Why is everyone voting to close this? It is a legitimate question that I need an answer too and am doing as much research outside this as possible and keeping the topic updated with what I have tried so far... – MasterZ Jan 10 '12 at 21:19
  • It is a system administration question, not a programming question. You are more likely to get an answer on serverfault. – Zack Feb 11 '12 at 17:17

OMG! You are asking a question about a 10-year-old CUPS release running on a 12-year-old operating system...

Chances are, that no-one else reading this site will have this combo to try and reproduce this problem.

I used CUPS 1.1.14 at the time, and can remember there was a problem with banners when using them with implicit classes.

So the question is: do you have ImplicitClasses Yes|On|True in your cupsd.conf ?

Also: do you have a PostScript file named secret in your /usr/share/cups/data/banners/ directory ?

Finally: The CUPS "classification" does not work for "raw" queues or "raw" jobs.

Raw queues are those that don't have a PPD associated to them in /etc/cups/ppd/. That means any job pushed to them are printed without any filtering applied. Raw jobs are jobs that don't pass any filtering (even if sent to a non-raw queue) because the commandline says -o raw...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.