I realized that I will need a soundcard on the server to support sound using the remote desktop client. Should soundcards work which support Windows 7? Our server runs Windows 2011 Small Business edition.

  • 1
    You do not need a sound card on a terminal server. Where did tou get that idea? – Zoredache Feb 13 '12 at 15:52
  • I am testing to play a sound and I get somthing like "no device" inside the session. Then I was browsing the web and found that terminal services require a sound card on client and server. – weismat Feb 14 '12 at 14:07
  • Wherever you saw that is wrong. I am 100% certain anoout that. – Zoredache Feb 14 '12 at 16:24

I'd play it safe. Buy anything with a Windows logo somewhere on the box. Preferably something made by Creative Labs.


I think I've found your problem.. You don't need a sound card, but because you don't have one, the audio services for Remote Desktop Clients have been disabled. You can enable them by:

  1. Login as Administrator (either locally on the server or by Remote Desktop Connection).
  2. Start --> Administrative Tools --> Remote Desktop Services --> Remote Desktop Session Host Configuration.
  3. In the centre pane, right click the connection name 'RDP-Tcp' and select 'Properties'.
  4. Click the 'Client Settings' tab.
  5. In the 'Redirection' section, under 'Disable the following', uncheck both 'Audio and video playback' and 'Audio recording' and click 'OK'.
  6. You'll get a message box about changes being made, but current active sessions not changed, so if using a remote session, logout and login again.


P.S. This should work for all variations of Windows Server 2008 (including Widows Home Server 2011).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.