My server is under domain botoholic.com. I've started a dedicated hosting plan with the company Superhost.pl in Poland. My domain provider is Namecheap.com and my DNS is configured on the dedicated server with following nameservers: ns1.botoholic.com A ns2.botoholic.com A

Everything has worked fine since the beginning until 2:00am GMT+1 13.02.2012. I woke up to see that my server is down. Probably huge CPU load prevented anyone from accessing any of it's services for 12 hours. I've remotely restarted the server and it went back up. Then I could see bandwidth usage of my server gradually going down as if it was getting less and less visits every minute.

After 2 hours I found out that my domain botoholic.com can't be resolved. From that moment it's DNS hell and it's been 18 hours since that happened and I decided to write a post about it just to see if maybe anyone can help with some advice.

Here is proof from just-ping.com that my domain can't be resolved globally:


Strange thing is my nameservers ns1.botoholic.com and ns2.botoholic.com seem to be mainly working and are being resolved, but anyone I ask say they can't resolve their IPs.


One thing is that I have currently no idea why suddenly my server went down at 2:00am and then right after it went back up, the DNS went crazy and my domain cannot be resolved globally for some reason. Could it be due to my server getting compromised, DDoS and parent nameservers blacklisting it?

www.intodns.com/botoholic.com - shows that my nameservers can't be resolved which makes no sense as I can resolve them with no problems using 'dig' from my place and they return proper records.

I haven't changed any configuration on my server for a month, so I have no idea what could have caused the DNS problems.

Do you have any idea what I should check or did you have any similiar experience?

UPDATE: I've just received information from tech support that it's the hard disk malfunction. They are backing up data and replacing hardware now. Hopefully now this nightmare will end.

UPDATE2: Ok guys, the hard disk was replaced and everything is working perfectly fine now. Who would've thought. Thanks for help!


Your DNS servers are not responding, you should call your provider and have them fix it. In the meantime I would do the following to cut losses (assuming you know the IP address of your webserver): Register your domain name at some free DNS hosting service (http://freedns.afraid.org/ and http://www.zoneedit.com/ are on the first page of google search, though I haven't tried them) and add A record pointing to your web server's IP address, then go to namecheap.com control panel and change your DNS servers to new ones.

  • I can set up DNS on Namecheap.com as well, that would be the same thing right? If the techs don't resolve this issue in 3-4 hours I'll have to do it. Thanks for advice. – blackd0t Feb 14 '12 at 9:27
  • 1
    Sure, any reliable DNS service would do. About techs fixing things, if DNS service is down for 30 hours that provider would be out of my 'trusted' list for good. – Dusan Bajic Feb 14 '12 at 9:30

The DNS traversal checker at squish.net is extremely useful for diagnosing DNS issues. In this case, it says:

50.0% recvfrom failed from; No route to host - recvfrom(2) at ns2.botoholic.com (
50.0% recvfrom failed from; No route to host - recvfrom(2) at ns1.botoholic.com (

So your glue records are working fine, but your DNS servers cannot be contacted.

  • +1 for the shout to squish.net; they're invaluable for solving DNS problems. – nickgrim Feb 14 '12 at 21:48

I'm unable to get records back for either your domain or name server:

[root@dev ~]# dig ns1.botoholic.com

; <<>> DiG 9.7.3-P3-RedHat-9.7.3-8.P3.el6_2.2 <<>> ns1.botoholic.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 908
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;ns1.botoholic.com.     IN  A

;; Query time: 2431 msec
;; WHEN: Tue Feb 14 12:06:31 2012
;; MSG SIZE  rcvd: 35

[root@dev ~]# dig botoholic.com

; <<>> DiG 9.7.3-P3-RedHat-9.7.3-8.P3.el6_2.2 <<>> botoholic.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 47096
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;botoholic.com.         IN  A

;; Query time: 2434 msec
;; WHEN: Tue Feb 14 12:06:46 2012
;; MSG SIZE  rcvd: 31

How are your glue records set up?

  • Glue records with domain provider are set up as follows: ns1.botoholic.com A ns2.botoholic.com A – blackd0t Feb 14 '12 at 9:14
  • 2
    Glue records are working, the servers they point to aren't. So ns1/ns2 are all you can resolve. – David Schwartz Feb 14 '12 at 9:28
  • Are you able to trace route to any of these IPs? – blackd0t Feb 14 '12 at 9:32
  • @blackd0t I can traceroute all the way to them. The hop before either of them is – David Schwartz Feb 14 '12 at 9:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.