Is there a way to send the Ctrl-Alt-Del command to an RDP session (Windows Server 2008 R2) inside another RDP session (also Windows Server 2008 R2) without the first session catching it?

Ctrl+Alt+End and Ctrl+Alt+Shift+End do not reach the 2nd level session.

Top-level environment is Windows 7 Enterprise.

  • 2
    I've not used 2008, but is osk (On-Screen Keyboard) still available? – James O'Gorman Feb 14 '12 at 14:37
  • I also found a workaround of forcing the user to change their password next logon but the OSK allows the pass change without interrupting the session. – xddsg Feb 14 '12 at 14:51
  • OSK is still around. You should post that as the answer! – Greg Askew Feb 14 '12 at 14:52
  • @Tom - OSK works if the first session is Windows 2008. I haven't tried Windows 2003 though. You may want to post details about your environment. – Greg Askew Feb 14 '12 at 14:54
  • @GregAskew Thanks, post now contains environment information. – xddsg Feb 14 '12 at 14:59

Use the On-Screen Keyboard (osk.exe). You can press Ctrl-Alt-Del virtually!

(Note: you may need to hold the CTRL and ALT keys on your physical keyboard (Windows Server 2012-R2))

On-Screen Keyboard

| improve this answer | |
  • 18
    Holding ctrl-alt on the top-level machine and clicking the 'del' in the desired level OSK works. Clicking ctrl-alt-del (no keyboard presses) does not (even though it looks like it is holding the fucntion keys down). Simple and functionally equivalent to what I was looking for. – xddsg Feb 14 '12 at 15:15
  • Just used this to change my AD password on a Server 2012 machine. Worked really well! – Josh Earl Apr 9 '14 at 13:44
  • Thanks, RDP within an RDP within a VM had me really confused as to how to this this. Worked like a charm. It's odd that the sticky keys don't work, I thought the point of the OSK was to use if you only had a mouse. – Omar Kooheji Oct 21 '14 at 15:56

I found a way to make this work. I frequently work with nested RDP sessions that go in several levels deep. That's just how I prefer to work, especially with lots of VMs.

Keep in mind that my environment is primarily Windows 7 and Server 2008 R2.

Here's the scenario: I RDP from Computer A to Computer B and from Computer B to Computer C.

  1. If I want to send Ctrl+Alt+Del to Computer A, I type Ctrl+Alt+Del from Computer A

  2. If I want to send Ctrl+Alt+Del to Computer B, I type Ctrl+Alt+End from Computer A

  3. If I want to send Ctrl+Alt+Del to Computer C, I open the On-Screen Keyboard on Computer B and use it to type Ctrl+Alt+End, which sends Ctrl+Alt+Del to Computer C

  4. If I try to use the On-Screen Keyboard to send Ctrl+Alt+Del on ANY of those three machines, it refers me to the Start menu, which does not help me at all.

So, to send Ctrl+Alt+Del to a remote machine, simply use the OSK to send Ctrl+Alt+End from the session just before the remote machine you are trying to send it to. Works every time.

| improve this answer | |
  • 3
    This is particularly helpful if 'Computer C' is Server Core. – user83664 Dec 26 '14 at 19:03

You can also create a shortcut that performs the CTRL-ALT-DEL action for you (very useful in environments where OSK is not accessible.) Create a shortcut to the following:

C:\Windows\explorer.exe shell:::{2559a1f2-21d7-11d4-bdaf-00c04f60b9f0}

Double-click that shortcut to access the CTRL-ALT-DEL screen.

| improve this answer | |
  • 1
    To me, running this from the command line seems most preferable. However, it didn't work for me. Maybe because I'm logged into WinSvr2008R2. Is this supposed to show a password prompt (using the GUI)? How'd you find this? (Is this documented somewhere?) I notice the same GUID referenced by HowToGeek: Turning a folder into a safe – TOOGAM Feb 10 '17 at 11:37
  • It was shown to me by a former co-worker some time ago. We were in an environment where we had to use nested RDP sessions, did not have OSK installed, did not have sufficient privileges to install OSK, and did not have a Windows Security shortcut. {2559a1f2-21d7-11d4-bdaf-00c04f60b9f0} is the CLSID for Windows Security. I do not know how to launch that from a command line, though. – Jarrod A. Feb 15 '17 at 15:47
  • i prefer this as it allows puts something on the desktop as a reminder – northern-bradley Mar 12 at 18:33

Set both RDP sessions to Send Windows keys to remote window.

enter image description here

Now, to send Ctrl-Alt-Del to the first session, use Alt-Ctrl-Del. To send commands to the second window, use Alt-Ctrl-End.

| improve this answer | |

There is another way you can specify where the Windows key combinations will be executed in the RDP Options Local Resources tab. In the section Keyboard you can choose On this computer, on the remote computer of Only when using the full screen. If you choose on the remote computer Ctrl Alt END will allow you to start a taskmanager in the nested rdp connection. Lifesaver if you managed to close the command Window on a core machine.

| improve this answer | |

I came across this solution but it didn't work for me. The OSK had been disabled and I couldn't bring it up. Found this works if you're only looking at a single nested RDP session.

i.e. Session B inside Session A.

Shift + Ctrl + Alt + End

| improve this answer | |
  • If you read the question, you'll see the asker tried this, but it didn't work. (Probably requires some fiddling with the RDP session settings, in his case.) – HopelessN00b Feb 6 '14 at 10:53
  • This worked for me (2008R2 onto 2008R2) but Session B had to be a non-full-screen window, with the focus, within A. (Session A was full-screen.) – mwardm Oct 16 '14 at 19:42

If you can setup TeamViewer or similar in the first session, Ctrl + Alt + End will then work for the second RDP session

| improve this answer | |

Do you need that shortcut or is your goal to start Task Manager? Last one can be done easier by hitting Ctrl+Shift+Esc - that also works with nested RDP sessions, as long as they are all in fullscreen

| improve this answer | |

I know this is old but I thought I would provide an answer as I figured out how to make the keyboard shortcut work. For me, I had to specifically use the Left Shift key and the Right Control and Alt keys and then press End to have it pass through to the second level RDP session.

I suggest anyone having issues with Shift+Control+Alt+End to try every combination they can on their keyboard to see if it works.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.