We have a Team Foundation Server 2010 set up using Kerberos. If we're accessing it via http://tfsserver:8080/tfs, everything's fine and users were never prompted for credentials. However if accessing it via http://tfsserver.domain.com:8080/tfs, then IE prompts for credentials. Has anyone experienced a similar issue? Thanks!

I tried IE, Firefox and Chrome and got the same result (Kerberos when using machine name, NTLM when using FQDN).


First thing to check on your client that the fqdn is in the Trusted Sites zone, and the Trusted Sites zone is configured to "Automatic logon with current username and password".

I would also be inclined to create an SPN for the url if it does not exist:


You can show the spn's like this:

setspn.exe -L tfsserver.domain.com
setspn.exe -L tfsserver.domain.com:8080
setspn.exe -L tfsserver
setspn.exe -L tfsserver:8080

  • Turned out tfsserver.domain.com was not detected as an Intranet site. After manually adding *.domain.com in the Intranet site list, the problem is gone. Thanks! – Jim Feb 17 '12 at 4:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.