I recently did a remote upgrade via SSH from Ubuntu 10.10 to 11.04, which seemed to go well, rebooted when prompted. I waited a while and tried to reconnect and could not via SSH.

After a little digging, it looks like this server is actually a guest running on ESXi 4.0. I don't have physical access to the system, however I can log into it via SSH.

If I run vim-cmd /vmsvc/getallvms I see the guest in question. vim-cmd /vmsvc/power.getstate 720 indicates that the guest is powered on.

I'm stuck here. I assume that the guest doesn't have a valid IP address or SSH is turned off. After a couple hours of googling I still do not know how to get a shell open to the guest via the host.

Can anyone help me figure this out?

  • 1
    So they don't allow you to use the vSphere Client? – Zoredache Feb 16 '12 at 1:05

As far as I know, there is no way to directly access a virtual machine console from the ESXi virtual server host.

Assuming that you have access to the VMware host server, you can use the VMware vSphere Client (from Windows) to access the system console. Click on the appropriate host, then on the Console tab. Click inside the console window to start typing at the console, and press Ctrl-Alt to escape the console window back to the local Windows machine.

  • Thanks @David. It took a bit to get vSphere running (had to get a windows VM since wine didn't like it). I now have access to a console. Some kind of issue with Grub. – hafichuk Feb 16 '12 at 1:26
  • You're welcome... I had problems running vSphere client inside a VM (used VirtualBox) but that was probably because it didn't have enough memory. Never was able to test it with a goodly amount of memory; 1Gb doesn't seem to be enough. Running with 2Gb is better - and the more the merrier. (This is the client we're talking about... sheesh.) – Mei Feb 16 '12 at 1:51

You're likely going to need to contact your provider to help you get on the console. ESXi does provide a method to access the real console of the server through the vSphere Client. You just need to find out if your provider will permit this. Some do, some don't. If they don't permit console access, I'd highly recommend finding another provider.

There's a small chance that a reboot will fix it, but that could also cause more issues, depending on what state the system is in now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.