1

I apologize to be opening another question with such a similar title, but

PPTP VPN - users cannot access internet via the server

does not quite cover the issue I'm encountering.

I have a VPN Server setup through Windows XP. I can successfully connect to this VPN from outside my network using PPTP. However, when I try to access a webpage, it times out. When I run a tracert, I get the following result:

tracert

I have verified that "Use default gateway on remote network" is CHECKED. It does appear it can connect to the VPN, but times out getting any further.

Thanks for any assistance!

**1st Edit:

Including picture of Incoming TCP/IP Properties:

enter image description here

**2nd Edit:

I've enabled TCP/IP routing per this guide: http://support.microsoft.com/kb/315236

I'm using a WRT160 Linksys router.

**Final Edit:

The issue came down to specifying an IP range within the router's valid IPs. For me this meant changing 10.0.0.10 to 192.168.1.100 and then 192.168.1.120 for the end of the range. Enabling/disabling IP routing did not have an effect.

1

You probably need to verify on the pptp server that it is correctly configured for

  1. routing packets
  2. nat-ing traffic
  3. allowing such traffic

Update: after discussion, what solved the problem was:

  • configuring the network range for the vpn clients in the same subnets as the one handled by the router which provides internet access.

    • Surprisingly enabling routing on the xp box does not make any difference!
  • I sure do! I also have access to the router that the server is sitting behind, which is a WRT160N. Just let me know where to start looking and I'll post edits to the question with the related info. – Nick Heidke Feb 16 '12 at 15:14
  • Ok, what kind of server is it? Windows or Linux? – Olivier S Feb 16 '12 at 19:50
  • It's actually a Windows XP machine, I used this guide to get this far: onecomputerguy.com/networking/xp_vpn_server.htm – Nick Heidke Feb 16 '12 at 19:54
  • I did not know XP was able to act as a VPN server. I suppose that you have to enable routing on it: support.microsoft.com/kb/315236 . Hopefully it will make it work – Olivier S Feb 16 '12 at 20:40
  • by the way, what range of IP addresses does your vpn server give to remote client? Did you opt for dhcp or did you specify a range yourself? – Olivier S Feb 16 '12 at 20:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.