1

Our upstream MTA is being temporarily disabled but responds with "550 contact support". This means all our automatically generated emails are going down the drain.

How do I configure Postfix so that the hard bounce is ignored and the mails deferred?

soft_bounce = "yes" does not help, because it only affects my own responses.

1 Answer 1

2

You're confusing a few things.

When an upstream SMTP server sends you a 550 response, that means the upstream server is rejecting your mail; it is not "being bounced".

Your server would be the one generating the bounce message in response to that 550.

soft_bounce = yes does in fact directly influence the above, and setting it means that your server reacts to every 5xx response with a defer action for later retry (up to the configured limit).

From the documentation:

soft_bounce (default: no)
Safety net to keep mail queued that would otherwise be returned to the sender. This parameter disables locally-generated bounces, and prevents the Postfix SMTP server from rejecting mail permanently, by changing 5xx reply codes into 4xx.

If you think this is not happening, include some logs that show this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.