I have several users that need access to a common mailbox, lets call it contact@domain.com. Each of the users have an AD account in domain.com, and have their own Exchange mailboxes. After doing some research, delegated mailboxes were ruled out because sent and deleted mail is kept in the delegate's folders, not the original mailbox's. I found that Outlook 2010 can have "Additional Accounts." Here's a good overview of those. The nice thing about the additional account is that it behaves identical to the users original mailbox (signatures, sent mail kept in sent folder, deleted mail kept in trash), and that the "from" address can be swapped quickly when writing an email.

I set up the users with the contact@domain.com mailbox, but have been having trouble since doing so. The first issue is that after adding the additional account, a credentials box pops up every time after opening Outlook. The user types in the user name as contact@domain.com, enters the password and checks for the credentials to be remembered. This worked fine for about a week. Now, some of the users are no longer able to send mail from the contact@domain.com account. A message pops up saying that they need "Send-As" permission. I don't understand why they would need permissions since they are logging in as that mailbox and should be treated as "owners." I've followed through several technet forum posts and tried several solutions, but nothing has worked yet.

Any ideas?


Couple of points here.

  • If the user has full permissions on the mailbox should not prompt you for credentials at all

  • Send as and send on behalf are two different things in exchange 2007/2010. One does not let one do the other. You cannot have both, one or the other.

  • Ensure inheritance is applied (for the SELF) under the user in AD > Security tab

  • Remember not to use both local Outlook setting (for delegation) and server, it should be one or the other but NOT both. I think (not 100% sure), the client overrides server setting. This in the past has caused many issues.

  • Having FULL permission does not mean you have 'Send-As or Send-On Behalf' permissions. You need to set this up separately.

  • I read somewhere once, although never tested myself that a restart on the Information Store helped. I wouldn't suggest this (especially during office hours), as this is not really resolving the issue, just a temp workaround (assuming it works for you)

  • Finally, i noticed it does take some time to update permissions, maybe just unlucky but wait at least 5 minutes before testing

| improve this answer | |
  • Thanks for the reply. The users should have full permissions as they're logging into the other account as if they were the owner. I wouldn't need to set any full permission settings on the exchange account when using the "additional account" type. – dmux Feb 21 '12 at 16:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.