I have a machine called server1 (windows server 2008). It was initially set to have an automatically assigned IP by the DHCP server (windows server 2008). It assigned it I changed server1 to have a static ip of I then deleted the reservation out of the DHCP server. On my local dev machine (windows 7) when I try to ping it it resolves to the old address. I've tried `ipconfig /flushdns' on all the machines, and I've tried rebooting etc. From server1 when I ping it by its name it resolves properly, just not from anywhere else. Is there some cache somewhere that needs to be cleared?

Thanks for the help.

  • It's like the WINS/NETBIOS resolution is getting cached. I've been trying nbtstat and arp to clear it, but not sure I'm doing it right. – Micah Feb 17 '12 at 18:33
  • 2
    ipconfig /registerdns – Mathias R. Jessen Feb 17 '12 at 18:34
  • @MathiasR.Jessen That doesn't seem to be working. Also if I run ipconfig /displaynds there's no entry for server1. – Micah Feb 17 '12 at 18:46
  • Cached result in the DC possibly? -- EDIT: Can you directly ping the fixed IP, and it's just the "Server1" failing to resolve or is the server inaccessible entirely? – Brad Christie Feb 17 '12 at 18:50
  • I don't have a DC setup. – Micah Feb 17 '12 at 18:52

Is that DHCP server also running as a DNS server? If so, clean up the host entry in DNS (delete and/or clear cache).

Update, 20120219

From an other post you made "Can't find computer by name only by IP address", I make up you do not have any internal naming resolution (like DNS, WINS or host-files).

My advice? Unless you want to return here every other month with resolving issues, get an internal DNS ASAP!

  • It's not. Just a DHCP server. We're not running an internal DNS server. – Micah Feb 17 '12 at 21:43
  • Just to be sure: the IP is not in the hosts-file either? – Henk Feb 17 '12 at 21:48
  • Yeah, no IP on hosts file. Did setup a WINS server (on same DHCP server). Will setup DNS on it also. – Micah Feb 20 '12 at 14:02
  • So... is your question answered then? Please accept my answer if it is. – Henk Feb 22 '12 at 16:05
  • Nope. Still no solution, – Micah Feb 22 '12 at 18:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.