I've got a SQL Server 2008 R2 Express running on a Windows Server 2008 R2 Web edition. Evertything works great except that the SQL service doesn't start automaticaly on server boot. The SQL Service, the agent and the server browser are set on automatic. The server is a clean install with an IIS and the sql server only. Once the server is started, I can start the service manually and it works just fine.

The only error I have in the log is "The SQL Server (SQLEXPRESS) service terminated with service-specific error The requested address is not valid in its context." In details, there is a param2 : %%10049.

Any help would be greatly appreciated since it is a production server. Each time it restarts, the website is down until I manually start the SQL service.


Is that error from the Windows Event log or the SQL Server Log? (It sounds like an Windows service error, not the sort of detailed error that would be reported by SQL and kept in it's error log.) The windows Event log is visible through the Event Viewer and the SQL Server log can be seen through SSMS.

It is pretty rare to not have decent error messages in one log or the other. If you haven't already, have a look in the SQL Server error log (including the older ones when the service fails) and see what looks different between a failed start and a successful start.

WAG: Is there something that prevents exclusive access to the file? Something like a virus scanner that scans on boot, or a SAN connection that takes a while to come online?

  • 1
    I found a message in the sql log. It might be related to a VPN setup. After a quick look, it seems SQL is trying to listen on an IP that only exist once the VPN is opened. Because, I use the VPN to connect on the server, when I start the service manually, this IP exist. Thanks for your help. – Benoît Feb 20 '12 at 22:04

Based on the additional info you provided regarding the VPN address, and the message from your original question, it sounds like you are on the right track.

You should have the SQL Server Configuration Manager installed on your server. Open this and locate

SQL Server Network Configuration

-> Protocols for "database name"

In the right hand side of the screen, open properties for TCP/IP

Once open, go to the IP addresses tab.

See if you can locate the IP address entry for your VPN address and change 'Enabled' to 'NO'.

Hopefully, that will allow the DB to startup by itself on a reboot. Let me know.

Original Answer: I don't have an answer as to why MSSQL is conking out on initial start, but you may be able to work around the issue until a full answer is found.

Open Services, bring up the properties for your SQL server service, and set the Recovery options and set the options to 'Restart the Service' on first, second and subsequent failures.

This should hopefully allow your SQL to get up and running after a reboot until you can find the root cause of the failure to initially start.

  • It's already set up like this. Unfortunately, it does not work until I do it manually. But I might have found something. See my comment in the post above. Anyway, thanks for your help. – Benoît Feb 20 '12 at 22:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.