The Sun Fire X4600 M2 Servers Service Manual says installing a shorting jumper across the P20 header pins will reset the SP password and clear the BIOS password. I installed the jumper then powered up the SP and the system fully as this note suggests:

You must allow the entire server, not just the SP, to reboot to main power mode to complete the password reset. This is because the state of the P20 jumper cannot be determined without the host CPU running. Wait until the end of POST, when you see the CMOS password cleared by jumper message, after which both the BIOS and SP passwords are reset.

I attached a monitor to the system and saw it saw CMOS password cleared by jumper, however I still cannot log into the SP / ILOM with what should now be reset to the default:

username: root
password: changeme

I tried logging in on the serial console, then via ssh as root and finally via the https method, but in all instances the changeme password did not work.

So far I have not tried re-installing or upgrading the firmware, but I'd rather avoid that unless I have to go that route.

Also, there is no password on the BIOS so I am able to get into that with no problems.

enter image description here

  • 1
    +1 for literal screenshot. – Wesley Feb 20 '12 at 3:36
  • @WesleyDavid I figured a photo of the screen would help head off people asking questions about whether I had installed the jumper properly or not. – aculich Feb 20 '12 at 5:57
  • 2
    Sun box, Dell Screen, Labelled Toshiba. Confusing much? ;p – Journeyman Geek Feb 28 '12 at 11:59
  • @JourneymanGeek Surely it could be worse... s/Sun/Oracle/g – aculich Mar 6 '12 at 5:10

Unfortunately, I have no extra insight on the reason why the jumper wouldn't work, but you can reset the password using ipmitool, with the commands:

ipmitool user list 1

<Find the appropriate user id in the returned list>

ipmitool user set password <userid> <newpassword>

Adapted from How to reset iLOM root password on Sun/Oracle X server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.