I'm working on a server running Red Hat Enterprise 6.2. I installed proftpd 1.3.3g using yum. Proftpd starts without any error messages, and it appears to be listening on port 21.

I would post an image that demonstrates this, but I'm still a new user so I'm not yet allowed to post images. When I run:

ps -ef | grep [PID]

I see:

nobody   [PID]   1   0   17:36 ?  00:00:00 proftpd: (accepting connections)

The command:

netstat -na | grep :21


tcp     0      0 :::21               :::*                     LISTEN

However, when I try to establish an FTP connection on port 21 using server's IP with Filezilla, it always times out. There is no response from the server whatsoever. I can immediately thereafter establish an SFTP connection on port 22 without a problem. Thus I can access the server via SSH and SFTP, but not FTP via proftpd.

I'm using the default configuration--I am currently using the default proftpd.conf. I have tried various edits to the file in my troubleshooting efforts, but I have not observed any change in behavior and I reset the proftpd.conf file to the original after each effort.

There appears to be no log information written by proftpd. I checked /var/log/proftpd/ and the directory was empty.

When I restart the proftpd service, which I've done plenty of times, it always gives [OK] for both the shutdown and startup.

So basically, I'm having trouble finding any leads as to what the problem could be.

1 Answer 1


Maybe a firewall is blocking your connection? Run iptables -nvL on server and look if 21 port is closed. Othewise try to connect to your server locally by ftp program.

  • Thanks for the answer galadog! unfortunately I can't post images, but here's the output of that command: Chain INPUT: pkts bytes target prot opt in out source destination 0 0 ACCEPT tcp -- * * tcp dpt:21
    – DeeDee
    Feb 20, 2012 at 16:57
  • To follow up on the above: I had made some edits to iptables after reading some howtos on other forums. There was no change in behavior after specifically adding these parameters
    – DeeDee
    Feb 20, 2012 at 17:00
  • Info from iptables means that there was no packets to server. Something blocks them before.
    – galadog
    Feb 20, 2012 at 17:04
  • Thanks! It's good to know that there's a possible source of the problem. Any suggestions on where I should look from here?
    – DeeDee
    Feb 20, 2012 at 17:09
  • I tried to telnet in using port 21, but it timed out. Your saying this: "Info from iptables means that there was no packets to server. Something blocks them before." helped me isolate the problem. Cheers!
    – DeeDee
    Feb 20, 2012 at 18:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.