2

I set up /etc/postfix/main.cf

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no
append_dot_mydomain = no
readme_directory = no
smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
myhostname = example.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = example.com, example02.com, mail01.example.local, localhost.example.local, localhost
relayhost = 
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128 192.168.1.0/24
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
home_mailbox=Maildir/

and

/etc/init.d/postfix restart

but.. You have new mail in /var/mail/user

Why? What's wrong?

5

According to the documentation, mailbox_command takes precedence over home_mailbox. Either disable the former, or set up your .procmailrc to deliver to Maildir (by suffixing the mailboxes with a slash, if memory serves).

2
  • Thank you very much. But... How to write .procmailrc? Could you give me a sample code? Jul 6 '09 at 5:57
  • 1
    Just get rid of the procmail call. If you don't know how to use it, then you don't need it.
    – womble
    Jul 6 '09 at 9:19
2

I agree with Michiel. I have the same setup, with procmail doing local delivery. I have the following in both /etc/procmailrc and my local .procmailrc files:

MAILDIR=$HOME/Maildir/
DEFAULT=$MAILDIR

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.