When I add new mailbox to Exchange 2010 (SBS 2011), for some reason default folders are in localized language, instead of English. Funny thing is that when we add mailboxes by adding a new user, folders are in English as they should be.

How to get default folders in English (in the first place), and how to rename or update these current folders? Is there a catch to do this from EMS?


2 Answers 2


Outlook system folders names assigned according to language of Outlook client used for first connection (profile creation). This folders cant be renamed.

To reset system folders names in English if it created with other language run Outlook with this user profile with /resetfoldernames commandline switch after changing the user interface language to English or installing a different language (English) version of Outlook.

  • Soon as I have created new mailbox, I have opened it using OWA and selecte Enlish as default language. Since I am not using Outlook, how can I reset folder names?
    – John
    Feb 21, 2012 at 14:21
  • Seems no ways to reset folder names using OWA, just "Outlook.exe /resetfoldernames". But if you use the only OWA - try to set PC locale and IE language preferences to English before starting OWA first time...
    – Sergey
    Feb 21, 2012 at 14:29
  • 2
    Oh... Since you using Exchange 2010 and OWA - you can try to configure default language for whole Outlook Web App as described in this MS article: technet.microsoft.com/en-us/library/aa997435.aspx
    – Sergey
    Feb 21, 2012 at 14:39
  • 3
    Found a solution. In OWA there is an option "Rename default folders so their names match the specified language" under Options > Settings > Regional!
    – John
    Feb 21, 2012 at 14:54

You can do it via PowerShell cmdlet Set-MailboxRegionalConfiguration. Details are here:


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .