ctrl + a under byobu has either emacs mode or screen mode. However, I need keybindings like ctrl + a for vim's "increment value" method. How would I prevent byobu/screen from blocking certain keyboard shortcuts?

Note: I get that the function commands are essential to switching screen tabs, so those can stay.. It's really just ther emacs style keybindings I'm trying to get rid of.


You have a couple of options...

  1. You can pass the ctrl-a through to vim by pressing ctrl-a then a again.
  2. You can switch byobu to use what we call emacs mode, where ctrl-a is not used as an escape (instead, the F12 is your escape).
  3. You can do this by running byobu-ctrl-a emacs You can change byobu's escape sequence entirely using F9 and selecting 'Change escape sequence'

Full disclosure: I'm the author and maintainer of Byobu.

  • 1
    i was having difficulty getting ctrl-a ctrl-a to work in vim, but after switching to emacs mode, everything works just fine. thank you for your help and byobu! – tester Feb 21 '12 at 21:03
  • Right, so as (1) notes, you'd press 'ctrl-a', let got of 'ctrl' and 'a', and then press an 'a' again. That would "pass through" the ctrl-a to the application below byobu. – Dustin Kirkland Feb 21 '12 at 21:19
  • Yes... but what about the other key bindings such as ESC-x that we use a lot in Emacs? It would be useful if we could momentaneously disable all key bindings while using an application that needs it, and then enable it all back when finished. For the record: sometimes I need to use emacs over an ssh session, so I have to use it inside the terminal. – user137603 Sep 19 '12 at 15:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.