I purchased a certificate from 123-Reg for my application, the problem is when I go to the url Brightlight I am getting the following message.

The certificate is not trusted because the issuer certificate is unknown. Error code sec_error_unknown_issuer. So people have mentioned that the intermediate certificate is need but I think that I have installed that as well as the main certificate.

This message seems to appear with Firefox and seems to be ok with the IEs

Any ideas?



You didn't install the certificate chain on your server.

Your cert is signed by "AlphaSSL CA - G2", which is itself signed by the root CA Cert, which is what browsers trust. Your server has to send the chain so browsers can follow it and figure out the trust.

  • I think I did and I ran a test using this site sslshopper.com/ssl-checker.html#hostname=https://…. Is this correct? – IconicDigital Feb 22 '12 at 18:55
  • Nope, still no intermediate chain certificate(s). The cert should have come with a separate chain file. 123-Reg doesn't have a standard repo, so they must be reselling for someone else. – Chris S Feb 22 '12 at 19:33
  • Looks like this page has the Intermediate (Chain) Certificates for AlphaSSL: alphassl.com/support/install-root-certificate.html Sorry I can't be more specific/helpful but most of these CA and their Resellers just plain suck; especially when there's free CAs out there who have their act together. – Chris S Feb 22 '12 at 19:35
  • Thanks for your help, I went over the settings I had in the virtual host file. I didn't realize that the settings were already set and were wrong in the main ssl.conf. The server was using these instead. – IconicDigital Feb 22 '12 at 19:54

Did you install the CA Certificate? Firefox will send this error when the CA is not there. IE will not...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.