I downloaded VM file with all its snapshots from vsphere to localhost. When I tried to open it with Workstation 8 - I got message The disk ...Debian.vmdk has internal consistency that were most likely caused by a host crush or host power failure. I've tried with http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1023856

but when I typed in my cmd window: vmware-vdiskmanager -R , I got message "Diskname or some other argument is missing". I'm trying for two days to solve that problem, and I'd really appreciate if someone told me how to fix this.

1 Answer 1


You do not mention any .vmx file, which is the virtual machine definition file that contains the relationship between the flat (base) .vmdk and any snapshots.

If you don't have that file, vmware has no way to apply any currently in-use snapshot files, and the original (flat) disk will appear to be inconsistent.

Copy over the .vmx file and try again.

Of course, if I am to take your post literally, and all you did was run "vmware-vdiskmanager -R", exactly like that, then yes, of course that fails.

Please read the documentation for your chosen product to find out how to use it.

  • I have .vmx file, and I run vmware-vdiskmanager -R D:\Location_of_VM\Debian-000002.vmdk and still didn't work Feb 22, 2012 at 14:24
  • So verify every single snapshot file mentioned in the vmx against what you actually have. Also try to edit a copy of the vmx file and remove the snapshots from it.
    – adaptr
    Feb 22, 2012 at 15:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.