1

I recieve the following error when I try to configure SharePoint 2010 Server:

"Cannot connect to the database master at SQL server at [computer.domain]. The database might not exist, or the current user does not have permission to connect to it."

I run the following setup:

  • Windows Server 2008 R2 Standard with SP1 and all the updates
  • SQL Server 2008 R2 with SP1
  • SharePoint Server 2010 with SP1
  • Everything is installed on the same server (it's a testserver)

I have tried the following:

  • Rebooting the server
  • Checking the install account's DB rights (dbcreator, securityadmin - I even let it have sysadmin)
  • Opened up the firewall on port 1433 and 1434
  • Uninstalled both SQL and SP, then reinstalled the both
  • Enabled all client protocols in SQL Server Configuration
  • Made sure I used the correct account for installing SharePoint (local admin)

Useful links: TCP/IP settings –> http:// blog.vanmeeuwen-online.nl/2010/10/cannot-connect-to-database-master-at.html

http:// ybbest.wordpress.com/2011/04/22/cannot-connect-to-database-master-at-sql-server-at-sql2008r2/

Wrong slash -> http:// yakimadev.com/2010/11/cannot-connect-to-database-master-at-sql-server-at-serverdbname-error-during-sharepoint-2010-products-configuration-wizard-and-installation/

Port error -> http:// www.knowsharepoint.com/2011/08/error-connecting-to-database-server.html

migrated from stackoverflow.com Feb 23 '12 at 2:10

This question came from our site for professional and enthusiast programmers.

  • Hello! Did you ever find a solution? – bgmCoder Nov 16 '12 at 1:03
-1

I know this is an old question, but, check the binding for your portal site in IIS. Click the "edit" button and make sure a certificate is chosen for your ssl binding. If there is no certificate (or it "came loose" somehow), you won't be able to access the site at all.

  • This has nothing to do with the configuration wizard failing with a database connection error. – Massimo Aug 17 '15 at 23:58
  • I beg to differ. Would you like to say why you think that? – bgmCoder Aug 18 '15 at 13:19
  • Because note being able to access the site (which may or may not be caused by a SSL issue) is a problem that could happen after running the Product Configuration Wizard; if the wizard itself fails, the problem is much more serious and the site hasn't even been brought online. – Massimo Aug 19 '15 at 1:38
  • Ah you may be right actually; but I do know that if your SSL certificate is out of whack that in SCA you may be able to access a page but the controls and wizards may yet fail. I've experienced this myself. – bgmCoder Aug 19 '15 at 13:34
  • He was referring to the initial wizard, the one which creates the farm and the SCA website. – Massimo Aug 19 '15 at 14:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy