When trying to edit file/folder permissions via FTP I am getting the error:

505 Security server forbids SITE commands. Contact admin.

I am currently using VSFTPD with the config value chmod_enable=YES set.

I also tried using ProFTPD instead but I got the same error.

I have two servers that are setup in a similar environment and they both report the same error.

I am struggling to find anything for that error through google and with it being ftpd server independant I am thinking it must be a system setting or maybe something intercepting the FTP command before it even hits my server if possible?

Would appreciate any help as I am having to do CHMOD commands through shell at the moment which isn't great as I would rather not require everybody to login to SSH.

Thanks in advance.


If two independent FTP daemons report the same error, the filesystem permissions for the FTP useraccount are insufficient to perform the chmod.

wat does ls -l /location/of/ftp/folder report ?

  • code drwxr-xr-x 2 user group 4096 Feb 23 11:25 cache drwxr-xr-x 4 user group 4096 Feb 23 11:26 libs drwxrwxr-x 2 user group 4096 Feb 23 14:20 templates_c I can confirm the correct user permissions are set, and I can run the chmod command at command line level. I think an immediate work around is to implement SFTP rather than FTP at our end – Adam Jessop Feb 23 '12 at 14:21

What I find most interesting about this issue is that neither the proftpd nor vsftpd source code bases have the string "Contact admin". This, to me, suggests that the error message your FTP client is receiving is not, in fact, coming from the FTP server.

A search on Google for that error string turned up a few different posts, all of which point toward the issue being a Checkpoint firewall, sitting between your FTP client and FTP server, being the culprit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.