2

I'm on Windows Server 2008. I'm using intoDNS to check I'm setting my DNS up correctly:

http://www.intodns.com/wewantogg.com

Everything looks fine for this domain except for the notice:

INFO: GLUE was not sent when I asked your nameservers for your NS records.This is ok but you should know that in this case an extra A record lookup is required in order to get the IPs of your NS records. The nameservers without glue are: 
209.126.137.108
209.62.64.46
You can fix this for example by adding A records to your nameservers for the zones listed above.

The name servers for this domain are:

ns12.zoneedit.com  ['209.62.64.46']   [TTL=7200] 
ns14.zoneedit.com  ['209.126.137.108']   [TTL=7200] 

I've added them as a forward lookup zone in my servers DNS manager:

enter image description here

Is this correct? It's still saying glue records have not been found and I'd like to resolve this if possible.

6

You misread the warning message from intoDNS. It is not your DNS servers that doesn't return the correct glue records, it's the nameservers at zoneedit.com that does not return glue records.

In short: This is not your fault/problem, it's the good people at zoneedit.com's problem

Otherwise, very decent test result btw

Update: About the MX record
If you are not going to use this domain to receive mail, don't take note of the "error". You may however want to add an SPF record, to help prevent spammers abuse your domain name for mail spoofing purposes.

To add an SPF record, create a record of RR-type: TXT, with this value:

v=spf1 -all

This way you let SPF parsers know that all mail pretending to come from @wewantogg.com should be rejected as SPAM

If you plan to introduce a mail server for sending and receiving (for example an Exchange organization), you can add mx to be allowed:

v=spf1 mx -all

This way you let SPF parsers know that mail pretending to come from @wewantogg.com should be rejected as SPAM unless it is sent from your MX

Read more about SPF here

  • 2
    Arguably it isn't much of a problem, it is means your lookups make result in a extra request. – Zoredache Feb 24 '12 at 1:53
  • @TomGullen you're welcome :-) – Mathias R. Jessen Feb 24 '12 at 2:05
  • Just glad to see someone actually interested in stopping email pollution! – Mathias R. Jessen Feb 24 '12 at 2:08
  • @zoredache any estimate on how much longer it would take for a client to resolve to the domain without glue? Would it be a good question to open? – Tom Gullen Feb 24 '12 at 2:16
  • 1
    @TomGullen the extra request won't add much time to the request if you even have to go all the way back to your DNS servers from the resolvers. – Jacob Feb 24 '12 at 2:47
3

The issue is something out of your hands Zoneedit needs to add Glue records and because your Nameservers aren't authoritative there isn't anything you can do or worry about. You can contact Zoneedit's support but it isn't a big deal.

The problem you should be concerned with is you have no MX records, those are what allow mail servers to send mail to each other. If you don't intend to send or receive mail at the domain this isn't a problem however if you want to get mail you need to enter one to reach your mail server

  • Thanks for the answer appreciate it! Not bothered with mail on this account for what it's worth. – Tom Gullen Feb 24 '12 at 2:06
  • 1
    Section 5 of RFC2821 clearly allow for MTAs to treat A records as implicit MX records, in the event that no MX or CNAME records exist for the domain in question (the current draft imply that AAAA records should be treated equally). So MX records is actually not a prerequisite for receiving email :-) – Mathias R. Jessen Aug 28 '13 at 23:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.