1

I am currently working on .xmls for imaging on mass deployment. I want to do an unattended join to the domain and also get the drivers in the audit (sysprep) phase. But when I go from audit to OOBE, I do a /generalize to cleanup the drivers I pushed down. [makes overall process a little faster, and the image smaller]

If I do the /generalize command from audit to OOBE, will that remove my [unattended] join to the domain?

2
  • are you using the waik\mdt tools from MS?
    – tony roth
    Mar 8 '12 at 14:38
  • WAIK yeah. I am trying to rename the computer before I join the domain within sysprep. But I don't know if it loads networking drivers in sysprep - So i can contact our DHCP and grab the assigned name. After which, I want to do an unattended join.
    – Zero
    Mar 8 '12 at 15:09
1
+50

If the nic drivers are not installed you should be able to add them to your winpe disk. If the NIC drivers are installed and you set the sections of WAIk PersistAllDeviceInstalls it won't clean them up. Also, the setting of DoNotCleanUpNonPresentDevices will leave any devices you installed but are not connected when you run sysprep. Here are instructions to install nic drivers to offline images using DISM. Might find some useful information here as well. doah.org There are known issues joining a domain in specialize since it joins the domain with a randomly generated name begining with "WIN-" it is noted in numerous technet articles

5
  • That's what I am trying to get rid of... The random generated name with "WIN-". Thank you for your input.
    – Zero
    Mar 9 '12 at 18:03
  • If you use MDT to deploy the image you can set up a sqlexrpress database and preload the mac address name and a few other options which will name it and such. This website has a guide to Using waik and mdt. Section 16 talks about setting up the database to input names. goo.gl/wQ0P
    – Phillip R.
    Mar 9 '12 at 18:19
  • Or you can have the sysprep image stop at the computer name screen and you can name it manually then use a powershell script to add-computer.
    – Phillip R.
    Mar 9 '12 at 18:32
  • Yeah, I wrote a powershell script to add the computer name before it joined the domain, it got the name via audit, but lost it when I tried joining the domain somewhere in OOBE (joined the domain with the WIN-...).I was figuring that generalize statemet was causing the issue.
    – Zero
    Mar 9 '12 at 20:54
  • If you remove the specialize pass stuff, which is what breaks the domain join, and put the join domain ps script in the FirstLogonCommands section of oobe it should work properly. This is a sample of my unattend.xml below. Or you can create a batch file after logon to do the name and add to domain. blog.doah.org/wp-content/uploads/2010/05/Unattend.txt The powershell script I use is the following: blog.doah.org/wp-content/uploads/2010/07/addcomputer.txt
    – Phillip R.
    Mar 9 '12 at 21:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.