4

I'm seeing some really odd issues with network speeds on my FreeNas 8.0.3 box. Receiving traffic is fine, but sending traffic slows down to 10-50kb/s, and stalls a lot.

Receiving: enter image description here

Transmitting: enter image description here

Iperf:

Server receiving: enter image description here enter image description here

Server sending: enter image description here enter image description here

ifconfig: enter image description here

sysctl -a | grep tcp

I have all other services disabled other than SSH and FTP. It's the issue on any volume I have on the machine. I've tried two different NICs, changed out cables, tried 3 different switches. I upgraded to 8.0.3 from 8.0.1 to see if it fixed this problem and it didn't.

This started happening seemingly out of the blue, any ideas on what may be wrong?

  • Look at the ifconfig output. Are there any collisions or anything? Can you do a test with something like iperf instead of scp, just to rule out anything to do with ssh/drive speeds and so on? – Zoredache Feb 25 '12 at 0:31
  • I added my ifconfig and iperf outputs. – AdamB Feb 25 '12 at 10:37
  • 1
    You do realize that you misspelled brontosaurus and also that the brontosaur is really a myth? It was just an apatosaurus with the head of a camarasaurus glued on. – Wesley Feb 27 '12 at 4:01
  • @WesleyDavid it's intentional... – AdamB Feb 27 '12 at 4:47
  • How much RAM does your box have? – duenni Feb 28 '12 at 9:51
1

This sounds like a possible duplex mismatch on your server and the network switch.

It looks like your nas box is set to 1gb full duplex. Is your network switch also set to 1gb full duplex?

  • I'm not sure. It's plugged into one of these dlink.com/DGS-2208. I get the same results no matter what switch I use. I've tried unplugging everything else except the server + client on the switch, same deal. – AdamB Mar 2 '12 at 3:10
  • is the light on the front of the switch where the server and client are green or amber? – pablo Mar 2 '12 at 3:45
  • the light is green – AdamB Mar 2 '12 at 6:16
  • 1
    Just try to connect your notebook directly to your FreeNAS. No need of a crossover cable. And/or enforce 100Mb/s speed (mii-tool with Linux, but I don't know by hearth with FreeBSD). – Gregory MOUSSAT Mar 3 '12 at 0:00
  • I tried forcing 100mbit and still the same issue. – AdamB Mar 5 '12 at 2:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.