1

I have had to reinstall MySQL, however the service is failing to start with the above cause listed in evnt viewer.

One solution is apparently to delete a couple of files prefixed with 'ib_logfile' which represent any old databases. However I do not have these files, and my service is still failing to start ... ? When I say I don't have these files I did a search using the windows search with zero results, and they are definitely not present in my mysql install directory. And I don't have the "documents and setting/appilcation data' folder referenced in link.

In fact I only have only one mysql install directory, I know where that is - what do I need to delete/change ? The instance is configured OK, I ran that as administrator and it is listed in services, but the service itself fails to start

Any tips, other than going over to postgresql ?

1
1

The linked solution helped me, I had to change the my.ini file in install directory, specifically this property to point at the correct location :

datadir="F:\MySQL\MySQL Server 5.5\data"

Which I got about 10 sec's after positing question, hey ho, will leave it up for others.

2
  • NimChimpsky u rockkkkk... correct solution. Keep it up. -Raj – user114773 Mar 21 '12 at 2:45
  • @Raj lol, thanks. You could just vote up though. – NimChimpsky Mar 21 '12 at 7:38
1

I had the same issue and here's what I did to fix it:

  1. Delete the following files:
    • C:\ProgramData\MySQL\MySQL Server 5.5\data\ib_logfile0
    • C:\ProgramData\MySQL\MySQL Server 5.5\data\ib_logfile1
  2. Launch services.msc and start the MySQL55 service.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.