I have a working deployment of Exchange 2010 and Lync Server 2010. I've successfully configured integration between the OWA web app and Lync, and when accessing OWA internally on the LAN chat and presence works.

I publish OWA using NGINX as a reverse proxy. When accessing OWA from the reverse proxy, lync integration is mostly non-functional. The symptoms are identical to the OP on this thread, to quote:

If I log into OWA through the web proxy I can't see status or contact lists in OWA, but I can click on a contact and initate a chat session, which is received by the other party. Any replies by the other part to the user logged in through the ISA/OWA site aren't received with a error similar to "username is active on a device that can't receive IM"

He fixed it by re-running the ISA publishing wizard, which doesn't tell me what exactly needs to happen to get it to work.

Has anyone successfully published OWA + lync integration on NGINX or apache?

  • I'm having a hard time finding any solid info on what the Lync integration is trying to do for its communication. Can you do some digging? A full capture of the HTTP communication in both working and non-working situations would be ideal, but probably not possible since it's HTTPS and adding a proxy to capture would likely break it. How about logs from nginx, and maybe some digging with browser dev tools on how the server's responding differently in both situations? Feb 27, 2012 at 17:11
  • @ShaneMadden I turned off ssl on the backend connection between nginx and OWA, and saved a wireshark transfer between nginx -> OWA and browser -> OWA. The difference seemed to be Connection: Keep-Alive was set in the working version and Connection: Close was set in the nginx version. It turns out stable Nginx does not support HTTP 1.1 proxies and therefore not keep-alive. I switched to apache mod_proxy and it works fine.
    – EMI
    Mar 4, 2012 at 4:41

1 Answer 1


Exchange OWA + Lync integration seems to require an HTTP 1.1 proxy, which Nginx stable does not support. Apache mod_proxy works fine, so I switched.

  • note: squid also works well
    – EMI
    Jan 18, 2013 at 23:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.