Mfg/Model: Samsung Droid Charge
Android Version: 2.3
Provider: Verizon
Error: Failed to connect

The user was previously receiving emails just fine on his phone, but since this morning, he hasn't been able to receive anything.

I don't believe this is a server issue because other Android users are able to connect without any issues.

I don't believe this is an account issues because

  1. The user can access Outlook and OWA without any issues, and
  2. I can access the user's account if I set it up on an iPhone

I don't believe this is a phone issue because

  1. I can setup an alternate user account on the Android phone and connect without any issues, and
  2. If I set the user's account up on a different Android phone, I also get the same result.

I've tried disabling/re-enabling the user account in AD, but this didn't seem to have any affect. I also tried changing the password to something else, and this too didn't seem to have any affect.

Debugging Log from Android:

[15:44:41] AbstractSyncService| Testing EAS: email.My_compnay_domain.com, My_Company_Domain\jdoe, ssl = 1
[15:44:50] AbstractSyncService| Validation (OPTIONS) response: 200
[15:44:50] AbstractSyncService| Server supports versions: 1.0,2.0,2.1,2.5
[15:44:50] AbstractSyncService| Try folder sync
[15:45:27] AbstractSyncService| IOException caught: Read timed out

As suggested, I also tried disabling/enabling Exchange ActiveSync policy, and also verified the Inheritable permissions.

Any suggestions would be appreciated.

  • Can you please add what version of Android this phone is running? – Nic Young Mar 2 '12 at 14:42
  • Also it would also help to know what version of Exchange you are running. – Nic Young Mar 2 '12 at 15:11

Well it has to be 1 of 3 things. Something changed in the AD account, something changed in the Exchange account or something changed on the phone itself. Can you enable debugging on the phone to ascertain why exactly the phone is throwing an error.

Follow these steps to enable debugging:

1. On the android phone go to menu -> email. You will need to have an already configured email account in order to enable debugging. If there is not one then you can simply add the User's gmail account. After this gmail account has been added go to the "Accounts" screen in the email app and type the following.


2. This should pop up a new screen with 4 checkboxes to enable enable debugging. Select all four check boxes and press the back button.

3. Now attempt to connect the User's phone to Exchange several more times so we get some good log data.

4. Connect the phone to a PC and Turn on USB storage.

The log should be located at the root of the phone's SD card and will be called emaillog.txt

Search the log for any pertinent error messages and look them up to ascertain the real reason behind the sync failure.


Well the log info that you have posted is fairly generic. So I am going to post a couple of things that have helped me in the past:

1. Attempt to disable the the Exchange ActiveSync policy on the User's mailbox and then attempt to re-enable. You could even try making a copy of your current EAS and have him point to that one instead to see if that does anything.

2. Under the User's Active Directory make sure Include Inheritable permissions from this object's parent is check marked. You can view this setting by doing the following:

  • In Active Directory Click View->Advanced Features
  • Right Click the User's account and go to the Security Tab
  • Click on Advanced
  • Check the box Include Inheritable permissions from this object's parent pic below:

enter image description here

| improve this answer | |
  • Nic, thanks for the suggestion. I'll give the debugging a shot and report back. – rb195048 Feb 29 '12 at 17:26
  • No problem. It would also help if you posted the andoid version the phone is running. – Nic Young Feb 29 '12 at 17:50
  • I've updated the question with the debugging info. The Android version is 2.3 – rb195048 Mar 2 '12 at 14:48

I have the same issue where OWA and Outlook is working. I tried setting it up on my phone and only emails/calendar/contacts/task would sync up to a certain date but nothing afterward. I tried syncing only 1 item (email/calendar/contacts/task) at a time with only the most current emails and emails start coming into my phone. Come to find out that there is a corrupted item, whether it be in emails/calendar/contacts or task. If you can locate and delete that corrupted item, you can free the path for Exchange ActiveSync to sync all your emails. If not, configure your setting to only sync after the date when you started having syncing problem.

| improve this answer | |
  • Deleting all of the SPAM in the inbox and junk email folders on/slightly after the date of the last successfully synced message did the trick for me. – NightOwl888 Feb 12 '19 at 12:07

I was able to resolve the issue by creating a new mailbox on my Exchange server and then reassigning the Active Directory account to the new mailbox. This left the user with 0 emails, however the user was now able to start syncing with his phone again. I'm currently in the process of migrating all his old emails back over to his new mailbox.

Before I took this step I tried creating a new Active Directory account and assigning the new user account to the old mailbox, but I ran into the same problem. So my last options was to try a new mailbox and that appears to have resolved the issue.

I'm guessing the Android phone wasn't able to sync because of a corrupt item in the mailbox.

| improve this answer | |

We just experienced a similar issue, but the user had never been able to add the account though.

It turned out to be the Inheritance that was disabled in AD on the user for some odd reason.

It wanted to add 75 permissions after I enabled it... afterwards the user could sync mail on a smartphone without problems.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.