I exported 2 virtual PCs from Hyper-V. and then imported them. I can't start one virtual machine that has Windows Server 2008 R2 installed. The machine starts, but then I only see a blinking underscore. I am trying to run these virtual PCs on Hyper-V 2008 R2 that is installed on bare metal.


Have you checked your boot order for the virtual machine? I have had this happen with bad ISO or image files and the virtual machine trying to boot from them. You can check the boot order from the Action menu for the Hyper-V Manager.

  • I exported that machine. Tried several times to prevent bad export. Imported on another machine, and not working here. Link to vhd file seems to be ok too... – martin Feb 29 '12 at 23:30
  • Changing boot order didn't helped... – martin Feb 29 '12 at 23:37
  • 1
    Boot from the 2008r2 DVD and attempt a boot repair or a repair installation. This will at least show whether the vhd file is connected and working. – G Koe Mar 1 '12 at 2:38
  • Win repair didn't helped. But in repair, I ran cmd and bootrec /fixmbr bootrec /fixboot bootrec /ScanOs bootrec /RebuildBCD solved my problem..... – martin Mar 1 '12 at 6:09
  • Well done. Now why is exporting your VHDs causing the bootmgr to loose your info? I have seen this happen when exporting from HyperV on 2008 and importing them on HyperV 2008R2... – G Koe Mar 1 '12 at 6:20

Load installation CD / DVD run repair and cmd and

bootrec /fixmbr

bootrec /fixboot

bootrec /ScanOs

bootrec /RebuildBCD

saved my life....

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.