I have a laptop running hostapd, phpd, and mysql. This laptop uses an Ethernet connection to connect to the internet and acts as a wireless access point for my workplace's wifi devices. After installing some software and reconnecting my Ethernet elsewhere, my "em1" device is no longer present and wirelessly connected devices can no longer reach the internet.

The software I recently installed is: pptp, pptpd, and updated some fedora libraries. I have also recently moved my desk and laptop to another location and thus had to reconnect the Ethernet elsewhere.

Wifi devices no longer have access to the internet. Wirelessly connected devices are able to successfully log into the laptop, showing full strength, correct SSID, and uses the proper password. However, when I tried to connect to a site like google, the request times out.

The device "em1" also no longer appears on my machine. Running: # ifup em1 will give me the following output: ERROR : [/etc/sysconfig/network-scripts/ifup-eth] Device em1 does not seem to be present, delaying initialization. And running: # dhclient em1 has the following output: Cannot find device "em1"

When I run # dmesg|grep renamed, I get the following: renamed network interface eth0 to p4p1. I've tried to connect to the internet through p4p1 directly from the laptop and was successful. However, my wireless devices connected to my laptop are not able to connect to the internet.

I have uninstalled pptp and pptpd using # yum erase ... but the problem still persists.

To install pptp I used: # yum install pptp

To install pptpd I did the following:

# rpm -Uvh http://poptop.sourceforge.net/yum/stable/fc15/pptp-release-current.noarch.rpm
# yum install pptpd

To update my fedora libraries I used:

# yum check-update
# yum update


Running # route produces the following results:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         UG    0      0        0 p4p1     *        U     0      0        0 p4p1    *        U     0      0        0 wlan0

This is a change that occurred with later versions of Fedora (15+). It is to create a more consistent naming.


You can see what the interfaces on your machine are named as using ifconfig -a. You should see the loopback (lo) and your new p4p1. You can start using p4p1 in places where you used to use em1. Or, according to the above doc (it is right at the end) you can revert to the old method by putting.


at the end of the kernel command line (my grub is in /etc/boot/grub.cfg). You may see multiple kernel lines there. Add the above to the end of the one you use but be careful not to b0rk your machine. If you don't know what you are doing, it may be better to just learn to love the new naming scheme.

  • Thanks for your answer. I already know em1 and p4p1 are new to FC15. However my issue is that I used to use em1, and now it is no longer there. Instead I find p4p1 which works, but wifi devices arn't able to connect to the internet anymore. I've revised my post to try to make my circumstances more clear. – Daniel Mar 5 '12 at 18:03
  • Previously, eth0 would have been renamed em1. eth0 is now being renamed p4p1. That is what I think your issue is (I always could be wrong). – webtoe Mar 5 '12 at 18:40
  • I duplicated all the ifcfg-em1 files I could find in /etc/..., renamed them to ifcfg-p4p1, and change the device field to DEVICE=p4p1. My wifi devices are still not able to connect to the internet. – Daniel Mar 5 '12 at 19:05
  • routing and NAT would also need to be altered. I assume you may also need to alter hostap (though I don't know much about it). What does route show? – webtoe Mar 5 '12 at 19:27
  • I've updated my original post to show the output of route. – Daniel Mar 5 '12 at 19:50

Installing the latest version of Fedora solved my problem. Although the device is still named p4p1, all modules that I was previously using works.

Another fix for this issue is to install Fedora 15, update it so that the name of the device changes, then install all of the software.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.