I have an account on a Linux server. Long time ago, I've setup an SSH key for logging. It used to work, and it continues to work until now. Right now, after I login on the server with my SSH keys, I tried issuing $ passwd, but I got Error: account is locked.

The problem is: there is an SVN service running on the server. The svn info uses an https URL. I used to be able to svn up from my home computer, and use my server account password to authenticate (the actual account password not my SSH key password). Right now, when I issue svn up it refuses my password. I think my password on the server has expired (or locked as in the error message in the previous paragraph).

I can't renew the account though. I'm stuck with the fact that I can SSH login with my key pair (even though my password/account has expired), but I can't update my SVN repo because the URL is https:// not svn+ssh:// (latter doesn't work).

Is there a (backdoor) way to successfully do svn up using my key pair (in an https+ssh:// fashion) such the I can authenticate using my key pair rather than my (expired) account login credentials?

1 Answer 1


You should really fix the root cause here: that the account is locked.

That said, you can change over to the svn+ssh protocol via svn relocate, assuming that the svn+ssh protocol actually works for access to the repo:

svn relocate svn+ssh://username@host/path/to/repo

But if you don't have changes pending a commit, and if the repo isn't prohibitively large, it's probably easiest to just do a new checkout.

  • Thanks. svn co svn+ssh://user@host/path/ does not work. It does allow me to login using my SSH key password, but after that it gives an error: svn: No repository found in 'svn+ssh://user@host/path/'
    – user60014
    Mar 5, 2012 at 22:46
  • Are you sure you have the right path? Keep in mind that the path presented by Apache is unlikely to be the same path as you'd need to use to access the repository over SSH. Mar 5, 2012 at 22:53
  • The https URL was https://user@host/myrepo. I logged using SSH and checked. There's a directory /svn/myrepo. I can browse there. So I tried svn co svn+ssh://user@host/svn/myrepo. Now it gives me the error: svn: Can't open file '/svn/myrepo/format': Permission denied.
    – user60014
    Mar 5, 2012 at 23:02
  • ls -l /svn/myrepo/format gives -rwx------ 1 apache apache 2 Sep 22 2008 format
    – user60014
    Mar 5, 2012 at 23:03
  • 2
    Yup, your user doesn't have access. That repository has been configured so that HTTPS is the only access method. Sorry, but this workaround won't work in this case; you'll need to resolve the issues with your account. Mar 5, 2012 at 23:06

You must log in to answer this question.