There seems to be a hard limit on incoming calls set a certain way- a telephone engineer told me about this, but I don't know the specifics. When on a call, the moment the call hits 15 minutes it drops. Does anyone know the specifics of this behaviour, and how to change it?

  • Are you using SIP or IAX? Sounds like a firewall/NAT/Masq problem to me: It's some timeout to keep a NAT entry alive. IAX would be TCP, SIP is UDP. – AndreasM Mar 6 '12 at 12:11

This is a classic symptom of a NAT session timing out on a firewall. Options without changing your firewall:

  • Look in the firewalls advanced firewall settings and see if you can see anything to do with session lifetime or expiry. Try extending this.
  • See if your firewall has a SIP ALG in it anywhere. This may just be called VoIP mode with a tick box, or it could be as complex as 10 pages of configuration. Experiment with enabling/disabling that. ALGs can often have good/bad effects but it totally depends on the firewall and scenario.
  • See if you can put the VoIP server on a routed rather than NAT'd network. Keep the firewall to shield it, but removing NAT entirely is a good cure for this. Some firewalls can this a DMZ zone, but be aware that the term DMZ in cheap SoHo firewalls can just mean 1-to-1 NAT with all ports open - this isn't what you want.
  • SIP ALG is disabled. Unfortunately the router isn't that good- but I've got a Cisco engineer coming to spec something this afternoon, so I'll make sure I ask him! – chrism2671 Mar 6 '12 at 12:45
  • 1
    If it's a crappy router, then NAT timing out is likely your problem. To test, open an SSH session to somewhere across the firewall. Type nothing and leave it connected, without null packets for keepalives etc. If that times out after 15 minutes, that's your proof. (Conversely however if it doesn't time out it doesn't rule it out either!) – SimonJGreen Mar 6 '12 at 12:47
  • 2
    And fire your telephone engineer, this has nothing to do with Asterisk. – StrangeWill Mar 8 '12 at 18:59

I had this issue yesterday with 1.6.x branch (stock in Debian Squeeze), it's due to faulty SIP session timers. The resolution is to use 1.8.x

In my case this was a simple dist-upgrade as Wheezy is now frozen and contains the 1.8.x branch.


  • You know, in the end we decided the best solution was to pay a company to come and install it. – chrism2671 Jul 24 '12 at 14:43
  • This was almost certainly the problem, this bug triggered at exactly 15 minutes every time. Firewall issues normally occur at the beginning or end of a call when some critical packets can be misplaced due to ALG issues. – Alex Recarey May 30 '13 at 18:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.