3

I'm using mysqldump to move the database to another server.

Everything works fine, except that mysqldump doesn't export all records from one table. The table contains about 500 records, and mysqldump exports only about 100 records.

I've noticed this problem after I exported an entire database, and then I tried to dump only this table, the same result. I've tried to increase the value of max_allowed_packets setting to 256M. I've also tried to disable extended inserts. This table contains TEXT fields if that helps (however, other tables with TEXT fields are exported successfully).

Also, mysqldump doesn't produce any errors, just skips some rows silently.

2
  • 1
    What is the exact command to export the DB? – patricks Mar 7 '12 at 10:33
  • I use mysqldump -u username -p dbname – Vladimir Kadalashvili Mar 7 '12 at 14:12
4

I've found the solution to this problem myself. The problem was that the table that I wanted to export was corrupted. I've repaired it, and now everything works fine.

Thanks

2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.