1

In one of my customers Linux box with CentOS 6.0 installed, I found that the user root is prohibited to alter any kernel parameters also editing the /etc/sysctl.conf throws permission denied.

In sudoers list root is given full access.

root    ALL=(ALL) ALL

I was unable to figure out what could prevent root from changing the values.

What can cause the root user to prevent doing any change in the kernel parameters ?

  • What error message is given when the root user tries to make a sysctl change? /etc/sudoers should have NO impact on the root user's privileges. – ewwhite Mar 7 '12 at 7:42
  • I am getting "Operation not permitted" error. – Supratik Mar 7 '12 at 7:48
  • What command are you running? – ewwhite Mar 7 '12 at 7:55
  • I tried both the commands 1. sysctl -w kernel.core_pattern=core.%e.%p 2. echo "core.%e.%p" > /proc/sys/kernel/core_pattern and both returned the same error. – Supratik Mar 7 '12 at 7:57
  • 1
    Is selinux or grsec enabled? – HampusLi Mar 7 '12 at 9:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.