1
minecraft@283823:~$ script /dev/null ; screen -t minecraft
  Script started, file is /dev/null
minecraft@283823:~$ exit
  Script done, file is /dev/null
Cannot open your terminal '/dev/pts/0' - please check.

My interpretation is I'm staying in the script /dev/null instead of running that to set up a new pts so I can screen as a su'ed user...

I'm testing my alias that does the same thing - script /dev/null ; screen. I tried doing this in a bash script the other day and I wound up with the same error.

2

This I believe is due to a safety feature that is present on Debian and Ubuntu distributions, if not most other Linux distributions. As previously mentioned a work around could be to change permissions of /dev/pts/* but I would strongly advice against it as it is a security risk.

0

Tried changing the permission on /dev/pts/0?

 chmod 666 /dev/pts/0

and then trying what you want to do.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.