XenServer 6.0.2 install fails no matter what I do. I have confirmed that the md5 checksum on my ISO file is good. I tried installing from a mounted ISO file (remotely via iKVM). I tried installing from physical media. I tried installing from a bootable USB stick (using syslinux + contents of the ISO)

All attempts have yielded the same result: When verifying the installation media, at 0% initializing, the following is reported: "Some packages appeared to be damaged." followed by a list of pretty much all the gz2 and rpm packages.

If I skip the media verification the installer proceeds and then gives me an error when it reaches "Installing from base pack" at 0% which states "An unrecoverable error has occurred. The error was: 'ascii' codec can't decode byte 0xff in position 20710: ordinal not in range(128) Please refer to your user guide, or contact a Technical Support Representative, for further details" there is one option left which is to reboot.

Apparently at some point during the processing of the repositories on the installation media non-ascii characters are found, which causes the installer to quit. How do I fix this?

Here are my specs

  • TYAN S8236 motherboard
  • 2 AMD Opteron 6234 processors
  • LSI2008 card connected to 2 1TB Seagate Constellation drives SATA, 1 500GB Corsair m4 SSD SATA and 1 Corsair Forse 3 - 64GB SSD SATA
  • Onboard SATA connected to a slim DVD-+RW.
  • Onboard SAS connected to 2 IBM ESX 70GB 10K SAS drives (for XenServer)
  • 256GB memory

================================================================================= Comments: According to pylonsbook.com "chances are you have run into a problem with character sets, encodings, and Unicode" – cmaduro 10 hours ago

A clue is provided by "vmware.com/support/vsphere5/doc/…; Data migration fails if the path to the vCenter Server installation media contains non-ASCII characters When this problem occurs, an error message similar to: 'ascii' codec can't decode byte 0xd0 in position 30: ordinal not in range(128) appears, and the installer quits unexpectedly during the data migration process. – cmaduro 10 hours ago

This is an error that python throws. And guess what, the .py extention of the file you have to edit in this link community.spiceworks.com/how_to/show/1168 means the installer is written in python. Python is interpreted, so now to find the install file responsible for this error. – cmaduro 6 hours ago

The file that generates the error upon verification is /opt/xensource/installer/tui/repo.py. The error message appears around line 359. – cmaduro 2 hours ago

I am fairly sure that the install error is generated somewhere in repository.py as the backend.py file throws errors while methods in that file are being called. Perhaps all errors can be traced back to this file. – cmaduro 1 hour ago

  • How about trying a different version installer? You could install (for instance) 6.0.1 and then upgrade the install. – Bill Weiss Mar 10 '12 at 15:03
  • I initially started with version 6.0.0 which also gave me the errors above. – cmaduro Mar 10 '12 at 23:48
  • Could you post the installer logs? If you wait until you receive the error, then switch to a different virtual terminal (ALT+F2) and run the command /opt/xensource/installer/report.py, you'll then be able to post the resulting archive here. – David Cottingham Mar 12 '12 at 11:44
  • Are there any special steps I need to take to use ALT-F2 other than just pressing the key combination? For example, should I run the installer after login into the shell at the initial installation prompt? I ask because when I press it nothing happens. – cmaduro Mar 12 '12 at 14:48
  • I'd go and run memtest on the machine, if only to exclude bad ram as possibility... – Hubert Kario Sep 10 '12 at 0:42

This is a bit tenuous, but I've seen XenServer fail in peculiar ways if it doesn't like the existing file system on the disk. You could try wiping your discs first.


I received this error when I enabled Intel C-STATE on the BIOS. Disabling this fixed it.

Motherboard: Asus P5Q Processor: Intel Core 2 Quad Q9400

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.