2

I'm trying to install VMware-vSphere-CLI-5.0.0-422456.x86_64 onto CentOS 6.0 64bit, but the installer complains:

CPAN not able to install following Perl modules on the system. These must be 
installed manually for use by vSphere CLI:

UUID 0.03 or newer

I tried to do

sudo yum install uuid-perl

and also

sudo yum install perl-SOAP-Lite perl-Data-Dump perl-Class-MethodMaker perl-Crypt-SSLeay perl-libxml-perl perl-XML-LibXML-Common

but this doesn't help.

What else can I try to do?

2
  • Not tempted to just use the vMA?
    – Chopper3
    Mar 16, 2012 at 17:04
  • @Chopper3: mmm... Can it be used from non-VMWare host and without human interaction? Then I definetely need to try this out.
    – weekens
    Mar 18, 2012 at 6:46

6 Answers 6

5

Make sure you have uuid, libuuid, and libuuid-devel installed from the yum repo. libuuid-devel was the key for me. (I was doing this on CentOS 6.4)

That should be enough for the vmware-install.pl script to do its thing, but you could also run: perl -MCPAN -e'install UUID' before you try the script again.

2
  • This resolved my issue on CentOS 6.4 with the uuid packages already installed.
    – Spechal
    Jul 16, 2013 at 18:02
  • I also missed Env and Fatal per packages
    – Bemipefe
    May 21, 2019 at 10:29
1

Like it says, you need to manually install it, because yum provides an old package. Head over to cpan and grab the latest (serving from failed memory I think it was http://search.cpan.org/~rjbs/Data-UUID-1.217/UUID.pm). Download, extract, change to the folder and run perl Makefile.pl and follow the instructions.

1
  • cpan provides its own package management system, controlled by the "cpan" command, so there are quicker ways to install than doing it manually with all dependencies - unless your distro chose to explicitly rip it out. Comes at the price of having to manage two package managers though :) May 21, 2012 at 19:14
1

I've got CentOS 6.2, and downloaded the Data::UUID as recommended in Tim's answer.

It seems Data::UUID and UUID are not the same. I found an unauthorized release of UUID 0.03 here; then, while trying to build it, I found out that the uuid-devel and libuuid-devel packages are not the same, and libuuid-devel is what's needed to build UUID 0.03. After that I found this, which seems to indicate that there's no need to build UUID 0.03; but after building and installing it, I was able to install the vSphere CLI.

0

Vsphere cli (even the latest version 5.1.) is not supported for rhel/centos newer than 5.5. Besides, getting all those perl dependencies installed is a nightmare anyway. IMHO, only run CLI on a windows system. Or better yet (if you're going to use windows anyway), forget about cli and just install power-cli for powershell.

0

I found that I was also missing the gcc package.

yum install gcc

After that I ran again the commands

perl Makefile.PL
make

and then I was able to install the vsphere cli

./vmware-install.pl

I hope that helps!

0

Here is what I did to install vCli from scratch (tested with CentOS 6.3) :

yum install perl-Archive-Zip perl-Class-MethodMaker perl-SOAP-Lite perl-libxml-perl perl-XML-SAX perl-Archive-Zip  perl-Class-MethodMaker perl-SOAP-Lite

Then I needed EPEL repository to install perl-Data-Dump with yum :

 yum install perl-Data-Dump

I tried perl-Data-UUID but it didn't work. So I did as jeremiahRo did :

yum install libuuid libuuid-devel

and then perl -MCPAN -e'install UUID worked with warnings.

./vmware-install.pl worked but some errors appeared :

The following Perl modules were found on the system but may be too old to work with vSphere CLI:

Compress::Zlib 2.037 or newer Compress::Raw::Zlib 2.037 or newer version 0.78 or newer IO::Compress::Base 2.037 or newer IO::Compress::Zlib::Constants 2.037 or newer LWP::Protocol::https 5.805 or newer

vCli seems to work now. I just ignored this messages.

PS : Sorry for my english...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .