I have CentOS machine and each time I've noticed that the server loses correct time after a while. It is usually behind by several minutes after time passes from having manually set the correct time. Is there a mechanism whereby I can update the server with the time from a specific time server?

up vote 105 down vote accepted

Use the ntp daemon. Run yum install ntp and ensure that the service is started via ntsysv or chkconfig ntpd on.

To get an immediate sync, run ntpdate time.apple.com (or something similar).

  • @ewhite I did yum and it is show ing is also already install. so what should be my next step? How to config my time to point to the ntp server? – user111196 Mar 12 '12 at 5:22
  • 3
    Try /sbin/service ntpd stop, followed by ntpdate time.apple.com and then /sbin/service ntpd start – ewwhite Mar 12 '12 at 5:36
  • 8
    @ewwhite Another solution is to run ntpdate -b -u time.nist.gov which will attempt to use a separate port than the ntpd daemon is using. – Shard Jan 7 '15 at 5:58
  • For me ntpdate worked without specifying a timeserver. – SPRBRN Mar 17 '15 at 12:38
  • In 2018 it is systemctl can you update? – YumYumYum Jul 10 at 8:54

You need to install and configure ntp.

yum install ntp
chkconfig ntpd on
ntpdate pool.ntp.org
service ntpd start

should get things set up and running. You may find that the ntp package is already installed and just needs configuring.

  • 2
    If the computer being changed is not a VM, then I hwclock -w after the ntpdate command. This means the next time the computer reboots, your clock will be less out-of-sync than it is now. – David Mackintosh Mar 12 '12 at 3:45
  • @lain I already check is install but what to config to point to the ntp server and keep it remain syn? – user111196 Mar 12 '12 at 5:23
  • @user111196: JUst perform the chkconfig, ntpdate and service commands above. – Iain Mar 12 '12 at 7:12
  • @lain what I am interest to learn on which time will it syn to is it my current time zone is it? – user111196 Mar 12 '12 at 15:59
  • Yes, the time will be correct for the time zone that your system is set to. – Iain Mar 12 '12 at 17:49

Yes.

NTP.

yum install ntp
chkconfig ntpd on

Do an initial sync, with

ntpdate pool.ntp.org

and start the time daemon with:

/etc/init.d/ntpd start
  • how to do the initial sync any command? You mean just run ntpdate pool.ntp.org but where is the time set? – user111196 Mar 12 '12 at 5:24
  • ntpdate sets the time. – Tom O'Connor Mar 12 '12 at 13:19
  • ntpdate set the date according to the server's time zone settings rite – user111196 Mar 14 '12 at 2:00
  • ntpdate sets the hardware clock. Whatever you're doing with /etc/timezone is a bit more userspacey. – Tom O'Connor Mar 14 '12 at 9:48

You'll need to configure ntpd for the server. I suspect it is already installed but needs to be configured. Note: if it is a virtual server, you probably have the option of syncing with the virtual host.

ntpd.

Ntpd does exactly what you're looking for - synchronizes your system clock with one or more known-good time servers.

Basically there are two ways. NTP daemon and the ntpdate command. The most important difference is that ntpdate will synchronize the time at once even though it means that the system time will change. On the other hand NTP daemon will take care of the time synchronization and it will adjust the time by small steps - you can think about it like slowing down/speeding up the time of the computer to synchronize it to the correct time. Thats why people suggest to do the initial synchronization by ntpdate and then leave it to ntp daemon.

Yea I'd use NTP, install ntp with yum and turn it on.

yum install ntp
chkconfig ntpd on

Then sync it to any ntp server of your liking with the ntpdate command

For centos 7.x installation:

yum install ntp
systemctl enable ntpd

initial sync, with:

ntpdate pool.ntp.org

start the daemon with:

systemctl start ntpd
  • 1
    CentOS 7 systems use chrony by default, so if you want to switch NTP clients you should disable or remove chrony first before installing ntpd. – Michael Hampton Apr 16 at 21:05
  • @MichaelHampton I have CentOS 7 and it didn't had chrony by default. – Unicornist Sep 10 at 7:10
  • @Unicornist You are only guaranteed to get chrony if you install from official CentOS media. If someone else performs the installation for you, or you use custom media, then you might not get it. – Michael Hampton Sep 11 at 23:20

Also if using CPanel like I was and had this issue. I think using rdate. Changing to ntpd as per above fixes all issues with email, especially dovecot,etc.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.