7

I have a working PXE boot server running on CentOS 5.5 that works perfectly for any flavor of Linux. I'm trying to add FreeBSD to the install options as a ISO memdisk, but so far nothing is working out. When I try to boot, I get the following:

Loading memdisk....Ready
MEMDISK 3.11 2005-09-02 Copyright 2001-2005 H. Peter Anvin
MEMDISK: No ramdisk image specified

Snippit from my /tftpboot/pxelinux.cfg/default. The CentOS install works fine, but the FreeBSD one fails.

default menu.c32
prompt 0
timeout 300
ONTIMEOUT local

MENU TITLE PXE Menu

LABEL CentOS 6.0 x86_64 NO KS eth0
        MENU LABEL CentOS 6.0 x86_64 NO KS eth0
        KERNEL images/centos/x86_64/6.0/vmlinuz nofb text
        APPEND initrd=images/centos/x86_64/6.0/initrd.img ramdisk_size=100000 ksdevice=eth0 

LABEL FreeBSD 9.0 NO KS eth0
        MENU LABEL FreeBSD9.0 AMD64
        kernel memdisk
        append iso
        initrd images/freebsd_isos/FreeBSD-9.0-RELEASE-amd64-bootonly.iso

I've tried "append iso raw", "append iso" and "append raw", but it does not appear to make any difference. I've also tried using the FreeBSD Memstick .img file and "append raw", but same results.

2
1

So, /tftpboot/images/freebsd_isos/FreeBSD-9.0-RELEASE-amd64-bootonly.iso exists correct?

LABEL FreeBSD 9.0 NO KS eth0
        MENU LABEL FreeBSD9.0 AMD64
        LINUX /memdisk
        APPEND iso
        INITRD /tftpboot/images/freebsd_isos/FreeBSD-9.0-RELEASE-amd64-bootonly.iso

This should work. It's of the format of what I have used.

1
  • Yes. I did get further by upgrading syslinux to the newest version. That allowed the iso to load, but then it got stuck at a mountroot> prompt. ? shows the local disks, however the iso root is not available.
    – John P
    Mar 13 '12 at 19:18
0

I also have come across John P's problem, and the solution to me was, unarchiving the iso file, edit the /etc/fstab file by commenting the line that mounts the iso, and then re-archiving it to an iso file, which later could boot normally to me.

The same process that doesn't involve a pxelinux.cfg entry also worked for me, what I only need to do is in the dhcp server configuration, setting the option root-path to the nfs location, and filename to the boot/pxeboot (for legacy), or the boot/loader.efi (for uefi). and finally comment the unarchived etc/fstab line in the nfs directory.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.