I have a website build on Typo3 and when I go to update it, I need to use IE, I can't get to edit anything when I open it with Firefox. Cookie Problem? Then the second problem, much harder to manage, is the session Time-out. Somehow it's logging me out after a few minutes, so I can't work on my translations... I already updated the configuration file (typo3conf/localconf.php) and set up the time to 1000000 seconds with this line "$TYPO3_CONF_VARS['BE']['sessionTimeout'] = 1000000;". If anyone finds something for me, it would be divine... Thanks.

  • You didn't tell us the OS and the TYPO3 version you are using. I run several TYPO3 sites (just now v4.2.8) and have no problems to access the backend with IE6, IE7, IE8, FF3.0 and FF3.5.2. But this was not the case with older versions of TYPO3 which had problems with some features of the backend or even RTE. – esc1729 Sep 4 '09 at 11:10
  • I'm using Typo3 4.0.3, and I run Windows XP. Do you think I could export the Website and all the files into a 4.2.8 to try? I'm always scared that files will get lost. Thanks for you help. – waszkiewicz Sep 7 '09 at 6:42
  • Yes of course you can and probably should do this. First have a look at the TYPO3 security pages typo3.org/teams/security if some of the issues apply to your version. There are several possibilities how to perform the update. You might find them discussed in the TYPO3 FAQ and wiki. Which way you want to go depends on the size of your site, if you have a lot frontend user interaction with forums, comment systems etc. in place, if you have patched some code yourself, etc. – esc1729 Sep 8 '09 at 10:49

I think you should do a new clean install, as I wrote in my comment above. Your installation is somewhat outdated and reinstalling everything might cure those problems. I think I remember there are also some security issues mentioned for all older versions beneath 4.2.8.

I myself, running Linux/Apache with a couple of virtual hosts, install all our TYPO3 sites into subdirectories like t3/ and use php-redirects on the corresponding web-roots.

  • When performing a major update I create a parallel directory like t3.new/ containing the empty default installation in the web-root and a new source directory in the document-root of the account. Then I update all my extensions and eventually patch them again to my needs. After this I copy the larger files and all those lots of resources which I do not want to down- and re-upload directly on the server and export/import the rest via .t3d files, excluding all those files from the backup. Then I set and check all the backend permissions for my editors. This is a little tedious but quite clean. When everything works as expected I delete the old t3/ directory and rename t3.new/ to t3/.

  • For smaller updates I only update the source-directory, re-link it and perform some DB checks and cleanups from the BE.

Of course your have to check the functionality of your site carefully. Use a tool like Xenu's Link Sleuth to check for broken links, etc., etc.

  • Ok, thank you. I will check this out and I'll come back to you. – waszkiewicz Sep 8 '09 at 13:32

Most likely it's a problem with cookies and caching, I had a similar issue in Firefox when I upgraded my own blog (not Typo3). If you go into Tools -> Options then Privacy, then click 'Show Cookies...' you can type your website's URL into the search box and then easily select and delete all the cookies. After that, hard refresh the login page (Ctrl F5) and try logging in again.

  • Tried but still the same problem. I also authorised in Typo3 all the IP addresses I use as Admin with NO logout, but always the same problem. – waszkiewicz Jul 28 '09 at 8:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.