1

The title says it all. We use Zenoss in a midsize network with lots of different Linux boxes. A lot of them have SMTP on by default, but we don't use it for anything; not on a single box. The Zenoss monitoring template "Status/IPService" keeps reporting various errors/timeouts for SMTP. Increasing the timeout threshold (zStatusConnectTimeout) fixes some of the timeout-related SMTP errors, but others persist. Apparently some of our unrelated configs screw SMTP up in some way.

I know I can filter out SMTP-related errors via an event view, but that feels like a band-aid solution. How do I disable Zenoss monitoring the SMTP service entirely? We don't use it, and probably never will (our mailservers aren't Zenoss monitored).

I'm fine editing .py files if I need to, but I'd hope that Zenoss provides some way to turn off monitoring of single services. I've RTFM, but all documentation just pointed me to the IPService template, which doesn't seem to have configurable settings.

2

In version 3.X... click Infrastructure at the top navigation, then click IP Services on the submenu. On the left use the search field to find SMTP. In the right side pane under "enable monitoring (zMonitor)" change the value to no.

remodel the device immediately and see if it stops monitoring smtp. you may have to restart the collector.

0

Same operation for Zenoss 4.x. If you want to do it on a device basis, just go to the ip services section under components and turn off monitoring for SMTP.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.