1

I'm trying to install some Ruby gems, and one called Rmagick, which interfaces with ImageMagick, is failing.

It's trying to find "Magick-config", but there does not appear to be any such animal in:

ImageMagick-6.5.4.7-5.el6.x86_64

Here's the specific failure:

Installing rmagick (2.13.1) with native extensions Unfortunately, a fatal error has occurred. Please report this error to the Bundler issue tracker at https://github.com/carlhuda/bundler/issues so that we can fix it. Thanks! /home/akwf/.rvm/rubies/ruby-1.9.3-p125/lib/ruby/site_ruby/1.9.1/rubygems/installer.rb:552:in `rescue in block in build_extensions': ERROR: Failed to build gem native extension. (Gem::Installer::ExtensionBuildError)

    /home/akwf/.rvm/rubies/ruby-1.9.3-p125/bin/ruby extconf.rb 

checking for Ruby version >= 1.8.5... yes extconf.rb:128: Use RbConfig instead of obsolete and deprecated Config. checking for gcc... yes checking for Magick-config... no

and then it bails.

UPDATE

I needed to get the rpm, since the ImageMagick-devel package I needed was not available in any RHEL6 yum repo that I knew how to find. Here's what I dug up:

yum install gcc-c++
yum install ImageMagick
yum install bzip2-devel
yum install freetype-devel
yum install jasper
yum install libX11-devel
yum install libXext-devel
yum install libXt-devel
yum install libjpeg-devel
yum install libtiff-devel

# Not available in RHEL6 yum repo
wget ftp://rpmfind.net/linux/centos/6.2/updates/x86_64/Packages/ghostscript-devel-8.70-    11.el6_2.6.x86_64.rpm
rpm -iv ghostscript-devel-8.70-11.el6_2.6.x86_64.rpm

# Not available in RHEL6 yum repo
wget http://mirror.centos.org/centos/6/updates/x86_64/Packages/jasper-devel-1.900.1-15.el6_1.1.x86_64.rpm
rpm -iv jasper-devel-1.900.1-15.el6_1.1.x86_64.rpm

# Not available in RHEL6 yum repo
wget ftp://195.220.108.108/linux/centos/6.2/os/x86_64/Packages/lcms-devel-1.19-1.el6.x86_64.rpm
rpm -iv lcms-devel-1.19-1.el6.x86_64.rpm

# Not available in RHEL6 yum repo
wget http://mirror.centos.org/centos/6/os/x86_64/Packages/ImageMagick-devel-6.5.4.7-5.el6.x86_64.rpm
rpm -iv ImageMagick-devel-6.5.4.7-5.el6.x86_64.rpm

Everything listed above the last rpm command are dependencies for install ImageMagick-devel. There may be a few more that I already had installed. If so, just Google the specific version and hunt it down on rpmfind or pkgs.org. If you find something, add it in a comment and I'll update this list.

1

Do you need to install an ImageMagick-devel package to get the development tools and headers?

EDIT Sorry - not a very useful answer - I was on my way out of the office.

Many software packages for Linux systems seem to be split into two parts - the main binaries, libs, docs, etc in one, and the development resources (header files, additional utilities and development documentation) in the other. In this case, the Magick-config utility is part of the ImageMagick-devel package.

  • Thanks a lot for the details. I was kind of stranded after wondering why the -devel package wasn't available in a yum repo for EL6. I had to get the rpm. Normally not a big deal until I ended up in dependency hell. I was able to work through it. Noted above. – user114055 Mar 16 '12 at 2:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.